terça-feira, 28 de outubro de 2014

Exercício Módulo 2 - Instruções Condicionais

Desenvolver um algoritmo para resolver o problema seguinte:


O algoritmo deverá ler um carácter, representando o estado civil, e um número inteiro, representando a idade do funcionário.

Cada aluno, individualmente resolve este problema, representando o algoritmo nas formas seguintes:

1 comentário:

Carlos Correia disse...

programa casado ou solteiro
declaracoes
cadeia a
inteiro b
inicio
escreva ("\nEs solteiro ou casado?\n")
leia (a)
escreva ("\nQual a tua idade?\n")
leia (b)
se (a="c") entao
se (b<34) entao
escreva ("\nEs do grupo 3")
senao
escreva ("\nEs do grupo 4")
fimse
senao
se (b<25) entao
escreva ("\nEs do grupo 1")
senao
escreva ("\nEs do grupo 2")
fimse
fimse
fim

Carlos Correia nº3