terça-feira, 21 de outubro de 2014

Exercício no WebPortugol


Fazer um programa para verificar se 3 valores reais podem ser as medidas dos lados de um triângulo. 

Resolver no WebPortugol e colocar a resolução num comentário a este post.

Cada aluno responde individualmente.

29 comentários:

Anónimo disse...

programa triangulo
declaracoes
real a
real b
real c
inicio
escreva ( "Insira um número:" )
leia (a)
escreva ( "\nInsira um número:" )
leia (b)
escreva ( "\nInsira um número:" )
leia (c)
se (a<b+c e b<a+c e c<a+b) entao
escreva (" \nSão medidas de um triângulo ")
senao
escreva (" \nNão são medidas de um triângulo ")
fimse
fim

Rui Monte n.º25

Anónimo disse...

programa extreme
declaracoes
real x
real z
real y
inicio
escreva( "Insira um número: " )
leia ( x )
escreva( "Insira um número: " )
leia ( z )
escreva( "Insira um número: " )
leia ( y )
se (x<z+y e z<x+y e y<z+x) entao
escreva( "\né um triângulo")
senao
escreva( "\né um triângulo")
fimse
fim

Tiago Monteiro nº28

Ronaldo Veloso disse...

programa triangulo
declaracoes
inteiro a
inteiro b
inteiro c
inicio
escreva ("\n Qual o primeiro lado do triangulo?")
leia (a)
escreva ("\n Qual o segundo?")
leia (b)
escreva ("\n Qual o terceiro?")
leia (c)
se ((a>b+c)ou(b>a+c)ou(c>b+a)) entao
escreva ("\nNao e um triangulo aceitavel!")
senao
escreva ("\nE aceitavel!")
fimse
fim


Ronaldo Veloso

Anónimo disse...

programa extreme
declaracoes
real x
real z
real y
inicio
escreva( "Insira um número: " )
leia ( x )
escreva( "Insira um número: " )
leia ( z )
escreva( "Insira um número: " )
leia ( y )
se (x<z+y e z<x+y e y<z+x) entao
escreva( "\né um triângulo")
senao
escreva( "\nnão é um triângulo")
fimse
fim

Tiago Monteiro Nº28

Ruben Morim disse...

programa triangulo
declaracoes
inteiro lado1
inteiro lado2
inteiro lado3
inicio
escreva ("\nQual o primeiro lado do triangulo?")
leia (lado1)
escreva ("\nQual o segunto?")
leia (lado2)
escreva ("\nQual o terceiro")
leia (lado3)
se ((lado1>lado2+lado3)ou (lado2>lado1+lado3) ou (lado3>lado2+lado1)) entao
escreva("\n Nao e um triagulo!")
senao
escreva ("\n E um Triangulo!")
fimse
fim


Ruben Morim nº24

Ricardo Lage disse...

programa segundotrabalho
declaracoes
real t
real w
real z

inicio
escreva ("Insira um número:")
leia (t)
escreva ("\ninsira outro número:")
leia (w)
escreva ("\ninsira outro número:")
leia (z)

se (z<w+t e w<z+a e t<w+z) entao
escreva ("\nÉ um triangulo")
senao
escreva ("\nNão é um triangulo")
fimse



fim

Ricardo Lage n° 21

Carlos Lopes disse...
Este comentário foi removido pelo autor.
Carlos Lopes disse...

programa triangulos
declaracoes
real a, b, c
inicio
escreva( "insira um número")
leia (a)
escreva( "Insira um número: " )
leia (b)
escreva( "Insira um número: " )
leia (c)
se (a<b+c e b<a+c e c<a+b) entao
escreva( "\né um triângulo" )
senao
escreva( "\nnão é um triângulo" )
Carlos Lopes nº2

Anónimo disse...

programa dvm
declaracoes
real d
real v
real m
inicio
escreva(" insira um numero:")
leia (d)
escreva(" insira outro numero:")
leia (v)
escreva(" insira so mais um numero:")
se (d<v+m e v<d+m e m<v+d) entao
escreva("\nÉ um trinagulo")
senao
escreva("\nNao é um tringulo")
fimse
fim

Anónimo disse...

programa triangulos
declaracoes
real a, b, c
inicio
escreva( "insira um número")
leia (a)
escreva( "Insira um número: " )
leia (b)
escreva( "Insira um número: " )
leia (c)
se (a<b+c e b<a+c e c<a+b) entao
escreva( "\né um triângulo" )
senao
escreva( "\nnao e um triângulo" )
fimse
fim


Diogo Pereira

Marcelo Cruz disse...

programa l

inteiro lado1
inteiro lado2
inteiro lado3


escreva ("\nQual o primeiro lado do triangulo?")
leia (lado1)
escreva ("\nQual o segunto?")
leia (lado2)
escreva ("\nQual o terceiro")
leia (lado3)
se (a<b+c e b<a+c e c<a+b)entao
escreva ("E TRIANGULO")
senao escreva ("NAO E TRIANGULO")
fimse
fim

Anónimo disse...

programa dvm
declaracoes
real d
real v
real m
inicio
escreva(" insira um numero:")
leia (d)
escreva(" insira outro numero:")
leia (v)
escreva(" insira so mais um numero:")
se (d<v+m e v<d+m e m<v+d) entao
escreva("\nÉ um trinagulo")
senao
escreva("\nNao é um tringulo")
fimse
fim
Diogo Matos Nº6

Anónimo disse...

programa
declaracoes
real l1
real l2
real l3
inicio
escreva ("\n Qual o primeiro lado do triangulo?")
leia (l1)
escreva ("\n Qual o segundo?")
leia(l2)
escreva ("\n Qual o terceiro?")
leia (l3)
se ((l1>l2+l3)ou(l2>l1+cl3)ou(cl3>l2+al1)) entao
escreva ("\nNao e um triangulo!")
senao
("\nE um triangulo!")
fimse
fim
Pedro Carreira nº19 tgp2

Joao Sencadas disse...

programa exercisio
declaracoes
real a,b,c
inicio
escreva( "\nInsira o primeiro numero" )
leia (a)
escreva( "\nInsira o segundo numero" )
leia (b)
escreva( "\nInsira o terceiro numero")
leia (c)
se (a<b+c e b<a+c e c<a+b)entao
escreva( "\nE triangulo" )
senao
escreva( "\nNao e triangulo" )
fimse
fim

Anónimo disse...

programa triangulo
declaracoes
real a
real b
real c
inicio
escreva ( "INSIRA O PRIMEIRO NUMERO:" )
leia (a)
escreva ( "\nINSIRA O SEGUNDO NUMERO:" )
leia (b)
escreva ( "\nINSIRA O TERCEIRO NUMERO:" )
leia (c)
se (a<b+c e b<a+c e c<a+b) entao
escreva (" \nE UM TRIANGULO ")
senao
escreva (" \nNAO E UM TRIANGULO ")
fimse
fim


José Cruz Nº11

Anónimo disse...

programa triangulo
declaracoes
real a
real b
real c
inicio
escreva ( "INSIRA O PRIMEIRO NUMERO:" )
leia (a)
escreva ( "\nINSIRA O SEGUNDO NUMERO:" )
leia (b)
escreva ( "\nINSIRA O TERCEIRO NUMERO:" )
leia (c)
se (a<b+c e b<a+c e c<a+b) entao
escreva (" \nE UM TRIANGULO ")
senao
escreva (" \nNAO E UM TRIANGULO ")
fimse
fim


Paulo Neves Nº18

Anónimo disse...

programa
declaracoes
real l1
real l2
real l3
inicio
escreva ("\n Qual o primeiro lado do triangulo?")
leia (l1)
escreva ("\n Qual o segundo lado do triangulo?")
leia(l2)
escreva ("\n Qual o terceiro lado do triangulo?")
leia (l3)
se ((l1>l2+l3)ou(l2>l1+cl3)ou(cl3>l2+al1)) entao
escreva ("\nNao e um triangulo!")
senao
("\nE um triangulo!")
fimse
fim
Pedro Carreira nº19

Carlos Escrivães disse...

programa Triangulo
declaracoes
real a, b, c
inicio
escreva("\ninsira um numero")
leia (a)
escreva("\ninsira outro numero")
leia (b)
escreva("\ninsira outro numero")
leia (c)
se ( a<b+c e b<a+c e c<a+b)entao
escreva("\ne um triangulo")
senao
escreva("\nnao e um triangulo")
fimse
fim

Anónimo disse...

programa triangulo
declaracoes
real p, h, y
inicio
escreva("\n Insira um número")
leia (p)
escreva("\n Insira um número:")
leia (h)
escreva("\n Insira um número:")
leia (y)
se (p<h+y e h<p+y e y<p+h) entao
escreva("\n é um triângulo") senao
escreva("\n não é um triângulo")
fimse
fim

Ricardo Nova nº 22

Tiago Parente disse...

programa triangulo
declaracoes
real t , i ,a
inicio
escreva( "\n Insira um número: " )
leia ( t )
escreva( "\n Insira um número: " )
leia ( i )
escreva( "\n Insira um número: " )
leia ( a )
se (t<i+a e i<t+a e a<i+t) entao
escreva( "\n sim é um triângulo")
senao
escreva( "\n nao é um triângulo")
fimse
fim
Tiago Parente nº27

Joao Faria disse...

programa triangulo
declaracoes
real a
real b
real c
inicio
escreva ("insira um numero")
Lado 1
leia (a,b,c)
Lado 2
se (a>c+c)
Lado 3
escreva ("Éum triângulo")
sendo
senao escreva ("Nao e um triângulo")
fimse
fim
João Fria nº10

Fábio Gomes disse...

programa segundotrabalho
declaracoes
real a
real b
real c

inicio
escreva ("insira um numero")
leia (a)
escreva ("\ninsira um numero")
leia (b)
escreva ("\ninsira um numero")
leia (c)
se (a<b+c e b<c+a e c<b+a) entao
escreva ("\ne um triangulo")
senao
escreva ("\nnao e um triangulo")
fimse


fim

Fábio Gomes nº7

Anónimo disse...

programa
declaracoes
real l
real c
real f
inicio
escreva ("\n Qual o primeiro lado do triangulo?")
leia (l)
escreva ("\n Qual o segundo lado do triangulo?")
leia(c)
escreva ("\n Qual o terceiro lado do triangulo?")
leia (f)
se (l>c+f)ou(c>l+f)ou(f>c+l)) entao
escreva ("\nNao e um triangulo!")
senao
("\nE um triangulo!")
fimse
fim
Luis Costa nº12

Anónimo disse...

programa segundotrabalho
declaracoes
real a
real w
real p

inicio

escreva ("Insira um número:")

leia (a)

escreva ("\ninsira outro número:")

leia (w)

escreva ("\ninsira outro número:")

leia (p)

se (a<w+p e w<p+a e p<w+a)

entao

escreva ("\nÉ um triangulo")

senao

escreva ("\nNão é um triangulo")

fimse

fim

Anónimo disse...

programa triangulo
declaraçoes
real l
real m
real n
inicio
escreva ("Insira um número")
leia (l)
escreva ("Insira um número")
leia (m)
escreva("Insira um número")
leia (n)
se (l<m+n e m<l+n e n<m+l)entao
escreva ("\nÉ um triangulo")
senao
escreva("\nNao é um triangulo")
fim se


fim
luis carreira nº13

Carlos Correia disse...

programa
declaracoes
real a
real c
real f
inicio
escreva ("Insira um numero:")
leia (a)
escreva ("Insira um numero:")
leia (c)
escreva ("Insira um numero:")
leia (f)

se (f<c+a e c<f+a e a<c+f)entao
escreva ("e um triangulo")
senao
escreva ( nao e um triangulo)
fimse



fim

Carlos Correia nº3

Alex Trifyutsyanu disse...

programa tribot
declaracoes
real a , b , c
inicio
escreva ("\ninsira o lado 1 ")
leia (a)
escreva ("\ninsira o lado 2 ")
leia (b)
escreva ("\ninsria o lado 3 ")
leia (c)
se ((a<b+c) e (b<a+c) e (c<a+b)) entao escreva("\nsao as medidas do triangulo")
senao escreva ("\nnao sao medidas de um triangulo")
fimse
fim


Alex nº17

Anónimo disse...

programa fazer triangulos
declaracoes
real lado1
real lado2
real lado3
inicio
escreva ("Insira um lado:")
leia (lado1)
escreva ("Insira um lado:")
leia (lado2)
escreva ("Insira um lado:")
leia (lado3)

se (lado3<lado2+lado1 e lado2<lado3+lado1 e lado1<lado2+lado3)entao
escreva ("e um triangulo")
senao
escreva ( nao e um triangulo)
fimse



fim

Helder Bocinha nº8
21 de Outubro de 2014 ás 12:46

Anónimo disse...

programa triangulos
declaracoes
inteiros lado 1
inteiros lado 2
inteiros lado 3
inicio
escreva(qualo primeirolado do triangulo?)
leia(lado1)
escreva (quantos segundos?)
leia(lado 2)
escreva(qual o treseiro)
leia(lado3)
se(lado1-lado2-lado3)ou(lado3-lado2-lado1)
escreva(nao e um triangulo)
senao
escreva(e um tiamgulo)
fimse
fim





Nuno sol nª16