quinta-feira, 30 de outubro de 2014

Exercício Módulo 2 - Instruções Cíclicas (2)

Resolver no WebPortugol o exercício que já foi apresentado neste post, com as alterações seguintes:
  • O programa deve pedir ao utilizador para inserir o nome;
  • No final deve apresentar uma mensagem do género:  
        Olá Pedro, a sua classificação é normal.
  • O programa pede sucessivamente os dados de entrada (nome, peso e altura) até ser lido, para um utilizador, um peso e uma altura iguais a 0.
Cada grupo coloca a sua resolução num comentário a este post.

14 comentários:

Anónimo disse...

programa imc
declaracoes
cadeia nome
real imc
real peso
real altura
inicio
escreva ("Insira o seu nome: ")
leia (nome)
escreva ("\nInsira uma altura: ")
leia (altura)
escreva ("\nInsira um peso: ")
leia (peso)
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como magro.")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como normal.")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é com peso excessivo.")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como obeso.")
fimse
fimse
fimse
fim



KBytes

Ronaldo Veloso disse...
Este comentário foi removido pelo autor.
Ronaldo Veloso disse...
Este comentário foi removido pelo autor.
Anónimo disse...

programa imc
declaracoes
cadeia nome
real imc
real peso
real altura
inicio
repita
escreva ("Insira o seu nome: ")
leia (nome)
escreva ("\nInsira uma altura: ")
leia (altura)
escreva ("\nInsira um peso: ")
leia (peso)
se (peso!=0 e altura!=0) entao
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como magro.\n")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como normal.\n")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é com peso excessivo.\n")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como obeso.\n")
fimse
fimse
fimse
fimse
enquanto (peso!=0 e altura!=0)
fim


KBytes

Anónimo disse...

programa pa
declaracoes
cadeia n
real imc
real p
real a
inicio
escreva ("Insira o seu nome: ")
leia (n)
escreva ("\nInsira uma altura: ")
leia (a)
escreva ("\nInsira um peso: ")
leia (p)
imc <- ((p) / (a*a))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como magro.")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como normal.")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é com peso excessivo.")
senao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como obeso.")
fimse
fimse
fimse
fim

Anónimo disse...

programa pa
declaracoes
cadeia n
real imc
real p
real a
inicio
escreva ("Insira o seu nome: ")
leia (n)
escreva ("\nInsira uma altura: ")
leia (a)
escreva ("\nInsira um peso: ")
leia (p)
imc <- ((p) / (a*a))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como magro.")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como normal.")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é com peso excessivo.")
senao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como obeso.")
fimse
fimse
fimse
fim

Spotify

Tiago Parente disse...

ograma peso_altura_imc
declaracoes
cadeia nome
real imc real peso real altura
inicio
escreva ("Insira o seu nome: ")
leia (nome)
escreva ("\Insira uma altura: ")
leia (altura)
escreva ("\Insira um peso: ")
leia (peso)
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\ola")
escreva (nome)
escreva (" a sua classificação é magro.")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\ola")
escreva (nome)
escreva (" a sua classificação é normal.")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\ola ")
escreva (nome)
escreva (" a sua classificação é peso excessivo.")
senao
escreva ("\ola ")
escreva (nome)
escreva (", a sua classificação é obeso.")
fimse
fimse
fimse
fim

Anonymous juniores

Anónimo disse...

programa imc
declaracoes
cadeia nome
real imc
real peso
real altura
inicio
repita
escreva ("Insira o seu nome: ")
leia (nome)
escreva ("\nInsira uma altura: ")
leia (altura)
escreva ("\nInsira um peso: ")
leia (peso)
se (peso!=0 e altura!=0) entao
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como magro.\n")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como normal.\n")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é com peso excessivo.\n")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como obeso.\n")
fimse
fimse
fimse
fimse
enquanto (peso!=0 e altura!=0)
fim

KBytes

Ricardo Lage disse...
Este comentário foi removido pelo autor.
Anónimo disse...

programa imc
declaracoes
cadeia n
real imc
real p
real a
inicio
repita
escreva ("Insira o seu nome: ")
leia (n)
escreva ("\nInsira uma altura: ")
leia (a)
escreva ("\nInsira um peso: ")
leia (p)
se (p!=0 e a!=0) entao
imc <- ((p) / (a*a))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como magro.\n")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como normal.\n")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é com peso excessivo.\n")
senao
escreva ("\nOlá ")
escreva (n)
escreva (", a sua classificação é como obeso.\n")
fimse
fimse
fimse
fimse
enquanto (p!=0 e a!=0)
fim

SPOTIFY

Ricardo Lage disse...

programa imc
declaracoes
real peso
real altura
real imc
cadeia nome

inicio
repita
escreva ("Insira o seu nome:")
leia (nome)
escreva ("\nInsira uma altura:")
leia (altura)
escreva ("\nInsira um peso:")
leia (peso)
se (peso!=0 e altura!=0)entao
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (nome)
escreva (" a sua classificação é magro\n")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (" a sua classificação é normal\n")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (" a sua classificação é peso excessivo\n")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (" a sua classificação é obeso\n")
fimse
fimse
fimse
fimse
enquanto (peso!=0 e altura!=0)
fim

Os zbi's

Ronaldo Veloso disse...

programa imc
declaracoes
real imc
real altura
real peso
cadeia nome
inicio
escreva ("Qual o teu primeiro nome?\n")
leia (nome)
escreva ("\nQual a tua altura? (Metros)\n")
leia (altura)
se (altura != 0) entao
escreva ("\nQual o teu peso? (Kg)\n")
leia (peso)
se (peso != 0) entao
imc <- ((peso)/(altura*altura))
se (imc<18.5) entao
escreva ("\nOlá ")
escreva (nome)
escreva (", és classificado como magro.")
senao
se ((imc>=18.5)e(imc<=24.9)) entao
escreva ("\nOlá ")
escreva (nome)
escreva (", és classificado como normal.")
senao
se ((imc>=25)e(imc<=29.9)) entao
escreva ("\nOlá ")
escreva (nome)
escreva (", estás classificado com peso excessivo.")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (", és classificado como obeso.")
fimse
fimse
fimse
fimse
fimse
fim



Os quim da lage!

Alex Trifyutsyanu disse...

programa imc
declaracoes
cadeia nome
real peso
real imc
real altura
inicio
repita
escreva ("Insira o seu altura: ")
leia (nome)
escreva ("\nInsira uma nome: ")
leia (altura)
escreva ("\nInsira um peso: ")
leia (peso)
se (peso!=0 e altura!=0) entao
imc <- peso/(altura^2)
se (imc < 18.5)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como magro.\n")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como normal.\n")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é com peso excessivo.\n")
senao
escreva ("\nOlá ")
escreva (nome)
escreva (", a sua classificação é como obeso.\n")
fimse
fimse
fimse
fimse
enquanto (peso!=0 e altura!=0)
fim



SORAKA & BANANAS

Anónimo disse...

programa imc
declaracoes
real imc,peso,altura
cadeia nome
inicio
escreva ("Insira o seu nome")
leia (nome)
escreva ("\Insira uma altura")
leia (altura)
escreva ("\Insira um peso")
leia (peso)
imc <- ((peso) / (altura*altura))
se (imc < 18.5)entao
escreva ("\ola")
escreva (nome)
escreva ("é magro.")
senao
se (imc>=18.5 e imc<=24.9)entao
escreva ("\ola")
escreva (nome)
escreva ("é normal.")
senao
se (imc>=25 e imc<=29.9)entao
escreva ("\ola ")
escreva (nome)
escreva ("tem peso excessivo.")
senao
escreva ("\ola ")
escreva (nome)
escreva ("é obeso.")
fimse
fimse
fimse
fim
0 bytes