terça-feira, 16 de dezembro de 2014

Árvore de Natal

Fazer no VisuAlg um programa que desenhe uma Árvore de Natal:




Há duas possibilidades de resolução:

1. Desenhar apenas a árvore que é apresentada na figura.

2. Desenhar uma árvore, com uma altura definida pelo utilizador.

Colocar a resolução num comentário a este post.

18 comentários:

Anónimo disse...

algoritmo "arvore"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", n, ".")

fimalgoritmo

Ricardo Nova Nº22

Anónimo disse...

algoritmo "arvore de natal"
// Função :
// Autor :João Pedro
// Data : 16/12/2014
// Seção de Declarações
var
i, n, k, j, l, w: inteiro
inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-2
w <- n
para i de 2 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval(" ")
para i de 3 ate n faca
para l de 2 ate w faca

escreva(" ")
fimpara
w<- w-6
escreva(" ")
para k de 2 ate k faca
escreva("*")
fimpara
k<+k<-4
escreval("\")
fimpara
para i de 2 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva(" Você escolhera o tamanho da arvore ", n, ".")

fimalgoritmo

fimalgoritmo

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :Diogo Pereira
// Data : 16-12-2014
// Seção de Declarações
var

inicio
escreval (" ")
escreval (" *")
escreval (" * F")
escreval (" *** E")
escreval (" ***** L")
escreval (" ******* I")
escreval (" ********* Z")
escreval (" *********** *")
escreval (" ************* N")
escreval (" *************** A")
escreval (" ***************** T")
escreval (" *** A")
escreval (" *** L")
escreval (" *** *")
escreval (" ******* ")
escreval (" ***** ")
escreval (" *** ")
fimalgoritmo

Anónimo disse...

algoritmo "arvoredenatal"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", n, ".")

fimalgoritmo

ruben morim nº24

Diogo Matos disse...

algoritmo "arvore"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n

para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", n, ".")

fimalgoritmo

Anónimo disse...

algoritmo "a minha arvore :)"

var
i, n, k, j, l, w: inteiro

inicio
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("escolha o tamanho ", n, ".")

fimalgoritmo

pedro carreira nº19

Ricardo L disse...

algoritmo "semnome"

var
a: inteiro
b: inteiro
c: inteiro
d: inteiro
k: inteiro
f: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (b)
limpatela

c <-1
f <- b

para a de 1 ate b faca
para k de 1 ate f faca

escreva(" ")
fimpara
f<- f-1
escreva("")
para d de 1 ate c faca
escreva("*")
fimpara
c<-c+2
escreval("")
fimpara
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
escreva("Arvore do tamanho ", b, ".")

fimalgoritmo

Ricardo lage n°21

Anónimo disse...

algoritmo "arvore"

var
a, b, c, d, f, g: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (b)
limpatela

c <-1
f <- b

para a de 1 ate b faca
para f de 1 ate g faca

escreva(" ")
fimpara
g<- g-1
escreva("")
para f de 1 ate c faca
escreva("*")
fimpara
c<-c+2
escreval("")
fimpara
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("***")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", b, ".")

fimalgoritmo

Luis Quinta nº14

Anónimo disse...

algoritmo "arvoredenatal"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("ESCOLHES-TE A ÁRVORE COM O TAMANHO ", n, ".")

fimalgoritmo

Ricardo Nova Nº22
José Ricardo Nº11
Paulo Neves Nº18

Tiago Monteiro disse...

algoritmo "arvore"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n

para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", n, ".")

fimalgoritmo

Tiago Monteiro

joao sencadas disse...

algoritmo "Natal"
// Função :
// Autor :
// Data : 16/12/2014
// Seção de Declarações
var
inicio
escreval(" * ")
escreval(" *** ")
escreval(" ***** ")
escreval(" ******* ")
escreval(" ********* ")
escreval(" *********** ")
escreval(" ************* ")
escreval(" *************** ")
escreval(" ***************** ")
escreval(" ******************* ")
escreval("********************* ")
escreval(" *** ")
escreval(" *** ")
escreval(" *** ")
escreval(" *** ")
fimalgoritmo

joao sencadas n9

Rui Monte disse...

algoritmo "arvore"

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n

para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("***")
escreva("VOCÊ ESCOLHEU A ÁRVORE DE TAMANHO ", n, ".")

fimalgoritmo

joao sencadas disse...

algoritmo "Natal"
// Função :
// Autor :
// Data : 16/12/2014
// Seção de Declarações
var
inicio
escreval(" * ")
escreval(" *** ")
escreval(" ***** ")
escreval(" ******* ")
escreval(" ********* ")
escreval(" *********** ")
escreval(" ************* ")
escreval(" *************** ")
escreval(" ***************** ")
escreval(" ******************* ")
escreval("********************* ")
escreval(" *** ")
escreval(" *** ")
escreval(" *** ")
escreval(" *** ")
fimalgoritmo

joao sencadas n9

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/12/2014
// Seção de Declarações

var
d, n, k, x, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para d de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para d de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para x de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para d de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("O tamanho é de ", n, ".")

fimalgoritmo

Anónimo disse...

algoritmo "Natal"
// Função :ARvorezinha
// Autor :Diogo Flores
// Data : 16-12-2014
// Seção de Declarações
var

inicio
escreval (" ")
escreval (" *")
escreval (" ** ")
escreval (" *** ")
escreval (" ***** ")
escreval (" ******* ")
escreval (" ********* ")
escreval (" *********** ")
escreval (" ************* ")
escreval (" *************** ")
escreval (" ***************** ")
escreval (" *** ")
escreval (" *** ")
escreval (" *** ")
escreval (" ******* ")
escreval (" ***** ")
escreval (" *** ")

fimalgoritmo

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :
// Data : 16/12/2014
// Seção de Declarações

var
i, n, k, j, l, w: inteiro

inicio
// Seção de Comandos
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("O tamanho é de ", n, ".")

fimalgoritmo

Marcelo

Tiago Parente disse...

algoritmo "Árvore"

var
a, b, c, d, r, f: inteiro

inicio
escreval ("Escolha o tamanho da árvore.")
leia (b)
limpatela

c <- 1
f <- b
para a de 1 ate b faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para a de 1 ate b faca
para r de 1 ate f faca

escreva(" ")
fimpara
f<- f-1
escreva("/")
para d de 1 ate c faca
escreva("*")
fimpara
c<-c+2
escreval("\")
fimpara
para a de 1 ate b faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("escolha o tamanho ", b, ".")

Anónimo disse...

algoritmo "arvore de natal"

var
i, n, k, j, l, w: inteiro

inicio
escreval ("Escolha o tamanho da árvore.")
leia (n)
limpatela

k <-1
w <- n
para i de 1 ate n faca
escreva(" ")
fimpara
escreva(" ")
escreval("*")
para i de 1 ate n faca
para l de 1 ate w faca

escreva(" ")
fimpara
w<- w-1
escreva("/")
para j de 1 ate k faca
escreva("*")
fimpara
k<-k+2
escreval("\")
fimpara
para i de 1 ate n faca
escreva (" ")
fimpara
escreval ("|_|")
escreva("escolha o tamanho ", n, ".")

fimalgoritmo


LUIS CARREIRA Nº13