terça-feira, 2 de dezembro de 2014

Instrução de Seleção Múltipla

Procurar no tutorial sobre a linguagem VisuAlg (Ajuda -> A Linguagem VisuAlg) a instrução de seleção múltipla. Aplicar esta instrução na resolução do exercício seguinte:

- O programa principal lê um número compreendido entre 1 e 7, inclusive. Se o número lido estiver fora deste intervalo, o programa apresenta uma mensagem de erro.

- Dentro do programa principal, no caso de ter sido lido um número dentro do intervalo pretendido, é chamado um subprograma do tipo procedimento que recebe o número lido como parâmetro e escreve o dia da semana correspondente. Por exemplo, ao número 1 corresponde "Domingo", ao número 2, "Segunda-feira" e assim sucessivamente.

Apresentar a resolução deste exercício num comentário a este post.

24 comentários:

Ronaldo Veloso disse...

algoritmo "semnome"
// Função : Senefrei
// Autor : Tinstou
// Data : 02/12/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (d: inteiro)
inicio
escolha d
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda-feira")
caso 3
escreval ("Terça-feira")
caso 4
escreval ("Quarta-feira")
caso 5
escreval ("Quinta-feira")
caso 6
escreval ("Sexta-feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Número não reconhecido!")
fimescolha
fimprocedimento


inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Anónimo disse...

algoritmo "ola"
var
dia:inteiro
procedimento ddsm (d:inteiro)
inicio
escolha d
caso 1
escreval("domingo")
caso 2
escreval("segunda")
caso 3
escreval("terça feira")
caso 4
escreval("quarta feira")
caso 5
escreval("quinta feira")
caso 6
escreval("sexta feira")
caso 7
escreval("sabado")
fimescolha
fimprocedimento
inicio
escreva("Qual o número do dia?")
leia (dia)
ddsm (dia)
fimalgoritmo

Ruben Morim nº24

Anónimo disse...

algoritmo "PimboLimbo"
// Função : VlackVock
// Autor : José Ricardo nº 11 / Paulo Neves nº 18
// Data : 02/12/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (ds: inteiro)
inicio
escolha ds
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda_Feira")
caso 3
escreval ("Terça_Feira")
caso 4
escreval ("Quarta_Feira")
caso 5
escreval ("Quinta_Feira")
caso 6
escreval ("Sexta_Feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Numero não encontrado por favor experimente outro número!")
fimescolha
fimprocedimento


inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Anónimo disse...

algoritmo "PimboLimbo"
// Função : VlackVock
// Autor : José Ricardo nº 11 / Paulo Neves nº 18
// Data : 02/12/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (ds: inteiro)
inicio
escolha ds
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda_Feira")
caso 3
escreval ("Terça_Feira")
caso 4
escreval ("Quarta_Feira")
caso 5
escreval ("Quinta_Feira")
caso 6
escreval ("Sexta_Feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Numero não encontrado por favor experimente outro número!")
fimescolha
fimprocedimento


inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Anónimo disse...

Corrigido

algoritmo "ola"
var
dia:inteiro
procedimento ddsm (d:inteiro)
inicio
escolha d
caso 1
escreval("domingo")
caso 2
escreval("segunda")
caso 3
escreval("terça feira")
caso 4
escreval("quarta feira")
caso 5
escreval("quinta feira")
caso 6
escreval("sexta feira")
caso 7
escreval("sabado")
outrocaso
escreval("número não conhecido")
fimescolha
fimprocedimento
inicio
escreva("Qual o número do dia?")
leia (dia)
ddsm (dia)
fimalgoritmo

Ruben Morim nº24

Anónimo disse...

algoritmo "olá"
var
dia:inteiro
procedimento diaSemana(d:inteiro)

fimprocedimento
inicio
escolha d
caso 1
escreval("Domingo")
caso 2
escreval("segunda-feira")
caso 3
escreval("terça-feira")
caso 4
escreval("quarta-feira")
caso 5
escreval("quinta-feira")
caso 6
escreval("sexta-feira")
caso 7
escreval("sabado")
outrocaso
escreval ("Número inválido!")
fimescolha
inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)

fimalgoritmo

Pedro Carreira nº19

Anónimo disse...

algoritmo "hahahahahaha"
// Função : diogastica
// Autor : diogo
// Data : 02/12/2014
var dia: inteiro
procedimento diaSemana (d: inteiro)
inicio
escolha d
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda-feira")
caso 3
escreval ("Terça-feira")
caso 4
escreval ("Quarta-feira")
caso 5
escreval ("Quinta-feira")
caso 6
escreval ("Sexta-feira")
caso 7
escreval("Sábado")
caso 8
escreval ("Número não reconhecido.")
fimescolha
fimprocedimento

Carlos Correia disse...

algoritmo "Comando de Seleção Múltipla"
// Função : escolha dos dias
// Autor : CARLOS C.
// Data : 02/12/2014
var dia: inteiro
procedimento diasemana (d: inteiro)
inicio

escolha d

caso 1
escreval("Domingo")
caso 2
escreval("Segunda")
caso 3
escreval("Terça")
caso 4
escreval("Quarta")
caso 5
escreval ("Quinta")
caso 6
escreval ("Sexta")
caso 7
escreval ("Sabado")

outrocaso
escreval ("Número inválido.")
fimescolha

fimprocedimento

inicio

escreval("Qual o número que queres?")
leia (dia)
diasemana(dia)



fimalgoritmo

Rui Monte disse...

algoritmo "semnome"
// Função :
// Autor :
// Data : 02/12/2014
// Seção de Declarações
var
semana: inteiro
procedimento S (d:inteiro)
var
inicio
se (d=1)entao
escreval ("Domingo")
senao
se (d=2) entao
escreval ("Segunda-feira")
senao
se (d=3) entao
escreval ("Terça-feira")
senao
se (d=4) entao
escreval ("Quarta-feira")
senao
se (d=5)entao
escreval ("Quinta-feira")
senao
se (d=6)entao
escreval ("Sexta-feira")
senao
escreval ("Sabado")
fimse
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreva ("Insira um número entre 1 e 7: ")
leia(semana)
escolha semana
caso 1, 2, 3, 4, 5, 6, 7
S (semana)
outrocaso
escreval ("O número inserido inválido!")
fimescolha
fimalgoritmo

Anónimo disse...

algoritmo "dia da semana"
// Função :escolha multipa
// Autor : nuno sol
// Data : 12/2/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (ds: inteiro)
inicio
escolha ds
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda_Feira")
caso 3
escreval ("Terça_Feira")
caso 4
escreval ("Quarta_Feira")
caso 5
escreval ("Quinta_Feira")
caso 6
escreval ("Sexta_Feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Numero não encontrado por favor experimente outro número!")
fimescolha
fimprocedimento


inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Diogo Matos disse...

algoritmo "fine"
var
dia:inteiro
procedimento diasemana(d:inteiro)
inicio
escolha d
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda")
caso 3
escreval ("Terça")
caso 4
escreval ("Quarta")
caso 5
escreval ("Quinta")
caso 6
escreval ("Sexta")
caso 7
escreval ("Sábado")
outrocaso
escreval ("não existe esse dia da semana só existem 7 dias da semana!")
fimescolha
fimprocedimento
inicio
escreval("insira um numero do dia da semana")
leia(dia)
diasemana(dia)
fimalgoritmo

Diogo Matos Nº6

Anónimo disse...

algoritmo "Semana"
var
dia:inteiro
procedimento diasemana(d:inteiro)
inicio
escolha d
caso 1
escreval("domingo")
caso 2
escreval("segunda-feira")
caso 3
escreval("terça-feira")
caso 4
escreval("quarta-feira")
caso 5
escreval("quinta-feira")
caso 6
escreval("sexta-feira")
caso 7
escreval("sabado")
fimescolha
caso (>-8)
escreval("Não Reconhecido")
fimprocedimento
inicio
escreval("Qual o número do dia?")
leia (dia)
diasemana (dia)

fimalgoritmo

Ricardo Nova Nº22

Anónimo disse...

algoritmo "multipla"
// Função :
// Autor :Marcelo Cruz
// Data : 02/12/2014
// Seção de Declarações
var
dia:inteiro

procedimento dia semana(dia:inteiro)
inicio

caso 1
escreva ("Domingo")
caso 2
escreva ("Segunda-feira")
caso 3
escreva("Terça-feira")
caso 4
escreva("Quarta-feira")
caso 5
escreva("Quinta-feira")
caso 6
escreva("Sexta-feira")
caso 7
escreva("Sábado")
outrocaso
escreval ("ERRO!!!")
fimescolha
fimprocedimento

Tiago Monteiro disse...

algoritmo "semana"
// Função :
// Autor :
// Data : 02/12/2014
// Seção de Declarações
var
semana: inteiro
procedimento diaSemana(d:inteiro)
var
inicio
se(d=1) entao
escreva("Domingo")
senao
se(d=2)entao
escreva("Segunda-feira")
senao
se(d=3) entao
escreva("Terça-feira")
senao
se(d=4)entao
escreva("Quarta-Feira")
senao
se(d=5) entao
escreva("Quinta-Feira")
senao
se(d=6) entao
escreva("Sexta-Feira")
senao
escreva("Sábado")
fimse
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreva("Insira um número entre 1 e 7: ")
leia(semana)
escolha semana
caso 1,2,3,4,5,6,7
diaSemana(semana)
outrocaso
escreval("o número inserido é inválido")
fimescolha
fimalgoritmo

Anónimo disse...

algoritmo "christmas"
var
dia:inteiro
procedimento diasemana (d:inteiro)



fimprocedimento

inicio
escreval d
caso 1
escreval ("domingo")
caso 2
escreval ("segunda-feira")
caso 3
escreval ("terça-feira")
caso 4
escreval ("quarta-feira")
caso 5
escreval ("quinta-feira")
caso 6
escreval ("sexta-feira")
caso 7
escreval ("sabado")
outrocaso
escreval("numero nao identificado")
fimescolha
fimalgoritmo



LUIS CARREIRA Nº13

Anónimo disse...

algoritmo "smnome"
escolha d
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda-feira")
caso 3
escreval ("Terça-feira")
caso 4
escreval ("Quarta-feira")
caso 5
escreval ("Quinta-feira")
caso 6
escreval ("Sexta-feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Número não reconhecido!")
fimescolha
fimprocedimento

Anónimo disse...

algoritmo "kakakakak"
var
dia:inteiro
procedimento diaSemana(d:inteiro)

fimprocedimento
inicio
escolha d
caso 1
escreval("Domingo")
caso 2
escreval("segunda-feira")
caso 3
escreval("terça-feira")
caso 4
escreval("quarta-feira")
caso 5
escreval("quinta-feira")
caso 6
escreval("sexta-feira")
caso 7
escreval("sabado")
outrocaso
escreval ("Número inválido!")
fimescolha
inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)

fimalgoritmo
LUIS COSTA Nº12

Alex Trifyutsyanu disse...

algoritmo "semnome"
// Função :
// Autor :
// Data : 02/12/2014
// Seção de Declarações
var
dia : inteiro
procedimento diaSemana (dia:inteiro )
inicio
escolha dia
caso 1
escreval ("domingo")
caso 2
escreval ("segunda")
caso 3
escreval ("terca")
caso 4
escreval ("quarta")
caso 5
escreval ("quinta")
caso 6
escreval ("sexta")
caso 7
escreval ("sabado")
outrocaso
escreval (" Como e meuuu!? pedi de 1 a 7 -.-")
fimescolha
fimprocedimento
inicio
escreva ("escreva um numero de 1 a 7? ")
leia (dia)
diaSemana(dia)


fimalgoritmo

Anónimo disse...

algoritmo "semnome"
// Função : Senefrei
// Autor : Tinstou
// Data : 02/12/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (da: inteiro)
inicio
escolha da
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda-feira")
caso 3
escreval ("Terça-feira")
caso 4
escreval ("Quarta-feira")
caso 5
escreval ("Quinta-feira")
caso 6
escreval ("Sexta-feira")
caso 7
escreval("Sábado")
outrocaso
escreval ("Número desconhecido!")
fimescolha
fimprocedimento


inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Luis Quinta Nº14

joao sencadas disse...

algoritmo "diasemana"
// Função :
// Autor :Sencadas
// Data : 02/12/2014
var
diasemana: inteiro
procedimento diaSemana(d :inteiro)
inicio
escolha d
caso 1
escreval("Domingo")
caso 2
escreval("Segunda")
caso 3
escreval("Terça")
caso 4
escreval("Quarta")
caso 5
escreval("Quinta")
caso 6
escreval("Sexta")
caso 7
escreval("Sabado")
outrocaso
escreva("Erro")
fimescolha
fimprocedimento
inicio
escreva("Insira um numero de 1 a 7: ")
leia (diasemana)
diaSemana(diasemana)

fimalgoritmo



João Sencadas Nº9

Carlos Lopes disse...

algoritmo "diasemana"
// Função :
// Autor :Carlos Lopes
// Data : 02/12/2014
var
diasemana: inteiro
procedimento diaSemana(d :inteiro)
inicio
escolha d
caso 1
escreval("Domingo")
caso 2
escreval("Segunda")
caso 3
escreval("Terça")
caso 4
escreval("Quarta")
caso 5
escreval("Quinta")
caso 6
escreval("Sexta")
caso 7
escreval("Sabado")
outrocaso
escreva("Erro")
fimescolha
fimprocedimento
inicio
escreva("Insira um numero de 1 a 7: ")
leia (diasemana)
diaSemana(diasemana)

fimalgoritmo

Anónimo disse...

nicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Anónimo disse...

algoritmo "who cares?"
// Função : Sei la
// Autor : Diogo Pereira
// Data : 02/12/2014
// Seção de Declarações
var dia: inteiro
procedimento diaSemana (d: inteiro)
inicio
escolha d
caso 1
escreval ("Domingo")
caso 2
escreval ("Segunda")
caso 3
escreval ("Terça")
caso 4
escreval ("Quarta")
caso 5
escreval ("Quinta")
caso 6
escreval ("Sexta")
caso 7
escreval("Sábado")
outrocaso
escreval ("Erro!Número não reconhecido")
fimescolha
fimprocedimento
inicio
escreval("Qual o numero do dia?")
leia (dia)
diaSemana(dia)
fimalgoritmo

Tiago Parente disse...

algoritmo
var
semana: inteiro
procedimento dia Semana(d:inteiro)
var
inicio
se(d=1) entao
escreva("Domingo")
senao
se(d=2)entao
escreva("Segunda")
senao
se(d=3) entao
escreva("Terça")
senao
se(d=4)entao
escreva("Quarta")
senao
se(d=5) entao
escreva("Quinta")
senao
se(d=6) entao
escreva("Sexta")
senao
escreva("Sábado")
inicio
escreva("Insira um número de 1 a 7: ")
leia(semana)
escolha semana
caso 1,2,3,4,5,6,7
dia Semana(semana)
outrocaso
escreval("o número é inválido")
fimalgoritmo