quinta-feira, 27 de novembro de 2014

Exercício no VisuAlg - Funções e Procedimentos

Alterar o exercício deste post usando uma função para calcular a média e um procedimento para escrever a classificação qualitativa.

Cada aluno coloca a resolução num comentário a este post.

21 comentários:

Ricardo Lage disse...

algoritmo "semnome"
// Função :Notas
// Autor :Lage
// Data : 25/11/2014
// Seção de Declarações
var
um ,dois ,tres:inteiro
m :real
funcao media :real
var
med : real
inicio

med<-(um+dois+tres)/3
retorne med
escreval ("A média das suas notas é: " ,med)


fimfuncao
procedimento qua
var
inicio
escreval("a média inserida à classificada como : ")
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>4) e (m<10) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<14)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<18)entao
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)entao
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreval (" Escreva a primeira nota :")
leia (um)
escreval (" Escreva a segunda nota :")
leia (dois)
escreval (" Escreva a terceira nota :")
leia (tres)
m <-media
qua


fimalgoritmo




Ricardo Lage n° 21

Rui Monte disse...

algoritmo "semnome"
// Função : Média das Notas
// Autor : KnifeDeath
// Data : 25/11/2014
// Seção de Declarações
var
x, y, z :inteiro
m: real

funcao media :real
var
med :real
inicio
med<-(x+y+z)/3
retorne med
escreva ("A média das notas é:",med)
escreval("")
fimfuncao

procedimento Qua
var
inicio
escreva ("A média inserida é classificada como: ")
se (m>=0) e (m<5)entao
escreva ("Mau")
senao
se (m>=5) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimprocedimento
inicio
// Seção de Comandos
escreva ("Insira uma nota: ")
leia (x)
escreval("")
escreva ("Insira outra nota: ")
leia (y)
escreval("")
escreva ("Insira outra nota: ")
leia (z)
escreval("")
m<-media
Qua

fimalgoritmo

Anónimo disse...

algoritmo "semnome"
var
nota1, nota2, nota3 :inteiro
m: real

funcao media :real
var
med :real
inicio
med<-(nota1+nota2+nota3)/3
retorne med
escreva ("A média das notas é:",med)
escreval("")
fimfuncao

procedimento qua
var
inicio
escreva ("A média inserida é classificada como: ")
se (m>=0) e (m<5)entao
escreva ("Mau")
senao
se (m>=5) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimprocedimento

inicio

escreva ("Insira uma nota: ")
leia (nota1)
escreval("")
escreva ("Insira outra nota: ")
leia (nota2)
escreval("")
escreva ("Insira outra nota: ")
leia (nota3)
escreval("")
m<-media
qua

fimalgoritmo

Ricardo Nova N22

Anónimo disse...

algoritmo "soma"

var
x, y, z :inteiro
m: real

funcao media :real
var
med :real
inicio
med<-(x+y+z)/3
retorne med
escreva ("A média das notas é:",med)
escreval("")
fimfuncao

procedimento Qua
var
inicio
escreva ("A média inserida é classificada como: ")
se (m>=0) e (m<5)entao
escreva ("Mau")
senao
se (m>=5) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimprocedimento
inicio
// Seção de Comandos
escreva ("Insira uma nota: ")
leia (x)
escreval("")
escreva ("Insira outra nota: ")
leia (y)
escreval("")
escreva ("Insira outra nota: ")
leia (z)
escreval("")
m<-media
Qua

fimalgoritmo

Jose Ricardo nº11
Paulo Neves nº18

Diogo Matos disse...

algoritmo "mitos"
var
x ,y ,z:inteiro
w :real
funcao media :real
var
m: real
inicio

m<-(x+y+z)/3
retorne m
escreval ("A média das suas notas é: " ,m)


fimfuncao
procedimento q
var
inicio
escreval("a média inserida à classificada como : ")
se(w=0)e(w<=4)entao
escreval ("A média é má ")
senao
se (w>4) e (w<10) entao
escreval("A méda é medíocre ")
senao
se (w>=10)e(w<14)entao
escreval ("A média é suficiente ")
senao
se (w>=14)e (w<18)entao
escreval("A média é boa ")
senao
se (w>=18)e (w<=20)entao
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreval (" Escreva a primeira nota :")
leia (x)
escreval (" Escreva a segunda nota :")
leia (y)
escreval (" Escreva a terceira nota :")
leia (z)
w <-media
q
fimalgoritmo

Diogo Matos Nº6

Tiago Monteiro disse...

algoritmo "média"
// Função :
// Autor :Tiago Monteiro
// Data : 25/11/2014
// Seção de Declarações
var
a, b, c: inteiro
d: real
funcao media: real
var
med: real
inicio
med<-(a+b+c)/3
retorne med
escreval ("A média das suas notas é: ",med)
fimfuncao

procedimento Qua
var
inicio
escreval("A média das notas é: ",d)
se(d>=0) e (d<=4)entao
escreva("A sua média é mau")
senao
se(d>4) e (d<10)entao
escreva("A sua média é Medíocre")
senao
se(d>=10) e (d<=13)entao
escreva("A sua média é Sufeciente")
senao
se(d>13) e (d<18)entao
escreva("A sua média é Bom")
senao
se(d>=18) e (d<=20)entao
escreva("A sua média é Muito Bom")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreva("Insira a sua nota:")
leia (a)
escreval("Insira outra nota:")
leia (b)
escreval("Insira outra nota:")
leia (c)
d <-media
Qua

fimalgoritmo

Tiago Monteiro nº28

Carlos Correia disse...

algoritmo "mediadasnotas"
// Função :calcular a média das 3 notas
// Autor :Carlos C.
// Data : 25/11/2014
var
um ,dois ,tres:inteiro
m :real
funcao media :real
var
med : real
inicio

med<-(um+dois+tres)/3
retorne med
escreval ("A média das suas notas é: " ,med)


fimfuncao
procedimento qua
var
inicio
escreva("A média inserida pelas notas é classificada como : ")
se(m=0)e(m<=4)entao
escreval ("Média má ")
senao
se (m>4) e (m<10) entao
escreval("Média medíocre ")
senao
se (m>=10)e(m<14)entao
escreval ("Média suficiente ")
senao
se (m>=14)e (m<18)entao
escreval("Média boa ")
senao
se (m>=18)e (m<=20)entao
escreval("Média muito boa ")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreval (" Escreva a nota do primeiro teste :")
leia (um)
escreval (" Escreva a nota do segundo teste :")
leia (dois)
escreval (" Escreva a nota do terceiro teste :")
leia (tres)
m <-media
qua


fimalgoritmo

Anónimo disse...

algoritmo "procedimento"
// Função :
// Autor : João Faria
// Data : 27/11/2014
// Seção de Declarações
var
a,b: inteiro
procedimento soma ( x,y: inteiro)
var
res: inteiro
inicio
res<-a+b
escreval ("soma= " res)
escreva ("insira um primeiro numero")
leia (a)
escreval ("insira um segundo numero")
leia (b)
soma(a,b)
fimfunçao
procedimento
inicio
escreval("A média das notas é: ",b)
se(d>0) e (d<4)entao
escreva("A sua média é má")
senao
se(d>3) e (d<14)entao
escreva("A sua média é menos")
senao
se(d>=10) e (d<=11)entao
escreva("A sua média é suficiente")
senao
se(d>12) e (d<17)entao
escreva("A sua média é boa")
senao
se(d>17) e (d<20)entao
escreva("A sua média é Muito Boa")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreva("Insira a sua nota:")
leia (a)
escreval("Insira outra nota:")
leia (b)
escreval("Insira outra nota:")
leia (c)
d <-media

Anónimo disse...

algoritmo "funcao e procedimento"
var
n1, n2, n3 :inteiro
m: real

funcao media :real
var
m:real
inicio
m<-(n1+n2+n3)/3
retorne m
escreva ("A média das notas é:",m)
escreval("")
fimfuncao

procedimento Qualidade
var
inicio
escreva ("A média inserida é classificada como: ")
se (m>=0) e (m<5)entao
escreva ("Mau")
senao
se (m>=5) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimprocedimento
inicio
// Seção de Comandos
escreva ("Insira uma nota: ")
leia (n1)
escreval("")
escreva ("Insira outra nota: ")
leia (n2)
escreval("")
escreva ("Insira outra nota: ")
leia (n3)
escreval("")
m<-media
Qualidade

fimalgoritmo

Pedro Carreira nº19

Anónimo disse...

algoritmo "naotenhonome"
var
um ,dois ,tres:inteiro
m :real
funcao media :real
var
med : real
inicio

med<-(um+dois+tres)/3
retorne med
escreval ("A média das suas notas é: " ,med)


fimfuncao
procedimento qua
var
inicio
escreva("A média inserida pelas notas é classificada como : ")
se(m=0)e(m<=4)entao
escreval ("Média má ")
senao
se (m>4) e (m<10) entao
escreval("Média medíocre ")
senao
se (m>=10)e(m<14)entao
escreval ("Média suficiente ")
senao
se (m>=14)e (m<18)entao
escreval("Média boa ")
senao
se (m>=18)e (m<=20)entao
escreval("Média muito boa ")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreval (" Escreva a nota do primeiro teste :")
leia (um)
escreval (" Escreva a nota do segundo teste :")
leia (dois)
escreval (" Escreva a nota do terceiro teste :")
leia (tres)
m <-media
qua


fimalgoritmo


Ruben Morim nº24 Tgp2

Anónimo disse...

algoritmo "semnome"
// Função :Notas
// Autor :Luis Quinta
// Data : 25/11/2014
// Seção de Declarações
var
um ,dois ,tres:inteiro
m :real
funcao media :real
var
med : real
inicio

med<-(um+dois+tres)/3
retorne med
escreval ("A média das suas notas é: " ,med)



Luis Quinta Nº14

Anónimo disse...

algoritmo "funcao e procedimento"
// Função :Media Qualitativa
// Autor :Marcelo Cruz
// Data : 25/11/2014
// Seção de Declarações
var
n1,n2,n3:inteiro
media: real
funcao media:real
var
media:Real
media<-(n1+n2+n3)/3
retorne media
escreva(" A sua media e de: ")
fimfuncao

procedimento
var
inicio

escreva("A sua media é de: ")
se (media>=0) e (media<=4) entao
escreva("A sua media e Mau")
senao
se (media>=4) e (media<=9) entao
escreva("A sua media e Mediocre")
senao
se (media>=10) e (media<=13) entao
escreva(" A sua media e Sufeciente")
senao
se (media>=14) e (media<=17) entao
escreva("A sua media e Bom")
senao
se (media>=18) e (media<=20)entao
escreva("A sua media e Muito Bom")
fimse
fimse
fimse
fimse
fimse

fimprocedimento


inicio
// Seção de Comandos
escreva("Insira primeira nota(0 a 20)")
leia(n1)
escreva("Insira segunda nota(0 a 20)")
leia(n2)
escreva("Insira terceira nota(0 a 20)")
leia(n3)

media<-(n1+n2+n3)/3

se (media>=0) e (media<=4) entao
escreva("A sua media e Mau")
senao
se (media>=4) e (media<=9) entao
escreva("A sua media e Mediocre")
senao
se (media>=10) e (media<=13) entao
escreva(" A sua media e Sufeciente")
senao
se (media>=14) e (media<=17) entao
escreva("A sua media e Bom")
senao
se (media>=18) e (media<=20)entao
escreva("A sua media e Muito Bom")
fimse
fimse
fimse
fimse
fimse

fimalgoritmo

Diogo Gamer e RxGamer disse...

algoritmo "Notas"
// Função : NOTAS
// Autor :Diogo Flores
// Data : 25/11/2014
// Seção de Declarações
var
a,b,c: inteiro
d: real
inicio
escreval("Escreva a primeira nota")
leia(a)
escreval("Escreva a segunda nota")
leia(b)
escreval("Escreva a terceira nota")
leia(c)
d<-(a+b+c)/3
escreval("A média das notas é:",d)
se(d>=0) e (d<=4) entao
escreval(A média é má!")
senao
se(d>=5) e (d<=9) entao
escreval("A média é medíocre!")
senao
se(d>=10) e (d<=13) entao
escreval("A média é suficiente!")
senao
se(d>=14) e (d<=17) entao
escreval("A média é boa!")
senao
se(d>=18) e (d<=20) entao
escreval("A média é muito boa!")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Ronaldo Veloso disse...

algoritmo "Notas"
// Função : Faz senefrei
// Autor : Ronaldo
// Data : 25/11/2014
// Seção de Declarações
var nota1,nota2,nota3: inteiro
nf: real

funcao media: real
var
med: real
inicio
med<-(nota1+nota2+nota3)/3
retorne med
escreval ("A média das notas é:",med)
fimfuncao

procedimento pro
var
inicio

se (nf>=0) e (nf<5)entao
escreval ("Mau")
senao
se (nf>=5) e (nf<10)entao
escreval ("Medíocre")
senao
se (nf>=10) e (nf<14)entao
escreval ("Suficiente")
senao
se (nf>=14) e (nf<18)entao
escreval ("Bom")
senao
escreval("Muito Bom")
fimse
fimse
fimse
fimse
fimprocedimento


inicio
escreval ("Insira 3 notas entre 0 e 20")
repita
escreval ("Nota 1?")
leia(nota1)
ate(nota1>=0)e (nota1<=20)
repita
escreval ("Nota 2?")
leia(nota2)
ate(nota2>=0)e (nota2<=20)
repita
escreval ("Nota 3?")
leia(nota3)
ate(nota3>=0)e (nota3<=20)
nf<-media
pro
fimalgoritmo



RONALDO Nº23

Anónimo disse...

algoritmo "luis"
var
n1 ,n2 ,n3:inteiro
m :real
funcao media :real
var
m: real
inicio

m<-(n1+n2+n3)/3
retorne m
escreval ("A média das suas notas é: " ,m)


fimfuncao
procedimento q
var
inicio
escreval("a média inserida à classificada como : ")
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>4) e (m<10) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<14)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<18)entao
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)entao
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse
fimprocedimento
inicio
escreval (" Escreva a primeira nota :")
leia (n1)
escreval (" Escreva a segunda nota :")
leia (n2)
escreval (" Escreva a terceira nota :")
leia (n3)
m <-media
q
fimalgoritmo

Luís Carreira

Tiago Parente disse...

var
n1, n2, n3 :inteiro
media: real

funcao media :real
var
media:real
inicio
media <-(n1+n2+n3)/ 3
retorne media
escreva ("Média das notas é:" media)
fimfuncao

procedimento
var
inicio
escreva ("Média é classificada como:")
se (media > =0) e (media < =5)entao
escreva ("Mau")
senao
se (media > =5) e (media < =10) entao
escreva ("Medíocre")
senao
se (media > =10) e(media < =14) entao
escreva ("Suficiente")
senao
se (media > =14) e (media < =18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimprocedimento

inicio

escreva ("Insira uma nota:")
leia (n1)
escreval("")
escreva ("Insira uma nota:")
leia (n2)
escreval("")
escreva ("Insira uma nota:")
leia (n3)

fimalgoritmo

Alex Trifyutsyanu disse...

algoritmo "aula"
// Função :
// Autor : Alex
// Data : 25/11/2014
// Seção de Declarações
var
procedimento resultado
var
inicio
se (media >=0) e (media<=4)entao
escreva ( media ,"=" , "Mau" )
fimse
se (media>4) e (media<10) entao
escreva (media, "=", "Mediocre")
fimse
se (media>=10) e (media<=13) entao
escreva (media, "=", "Suficiente")
fimse
se (media>13) e (media<18) entao
escreva (media,"=", "Bom")
fimse
se (media>=18) e (media<=20) entao
escreva (media,"=", "Muito Bom")
fimse
fimprocedimento

funcao calculo_media (nota1,nota2,nota3 :real):real
var
media: real
inicio
media <- (nota1+nota2+nota3)/3)
retorne media
fimfuncao
nota1,nota2,nota3 , media :real
inicio
escreva ( "Qaul a 1º nota?")
leia (nota1)
escreva ("Qual a 2º nota?")
leia (nota2)
escreva ("Qual a 3º nota?")
leia (nota3)
media<-calculo_media(nota1 , nota2 , nota3)
resultado


fimalgoritmo

joao sencadas disse...
Este comentário foi removido pelo autor.
Anónimo disse...

algoritmo "semnome"
// Função : Média das Notas
// Autor : nuno sol
// Data : 25/11/2014
// Seção de Declarações
var
x, y, z :inteiro
m: real

funcao media :real
var
med :real
inicio
med<-(x+y+z)/3
retorne med
escreva ("A média das notas é:",med)
escreval("")
fimfuncao

procedimento Qua
var
inicio
escreva ("A média inserida é classificada como: ")
se (m>=0) e (m<5)entao
escreva ("Mau")
senao
se (m>=5) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<18) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimprocedimento
inicio
// Seção de Comandos
escreva ("Insira uma nota: ")
leia (x)
escreval("")
escreva ("Insira outra nota: ")
leia (y)
escreval("")
escreva ("Insira outra nota: ")
leia (z)
escreval("")
m<-media
Qua

fimalgoritmo

Carlos Lopes disse...

algoritmo "Notas"
// Função :notas
// Autor :Carlos Lopes
// Data : 25/11/2014
// Seção de Declarações
var nota1,nota2,nota3: inteiro
nf: real

funcao media: real
var
med: real
inicio
med<-(nota1+nota2+nota3)/3
retorne med
escreval ("A média das notas é:",med)
fimfuncao

procedimento pro
var
inicio

se (nf>=0) e (nf<5)entao
escreval ("Mau")
senao
se (nf>=5) e (nf<10)entao
escreval ("Medíocre")
senao
se (nf>=10) e (nf<14)entao
escreval ("Suficiente")
senao
se (nf>=14) e (nf<18)entao
escreval ("Bom")
senao
escreval("Muito Bom")
fimse
fimse
fimse
fimse
fimprocedimento


inicio
escreval ("Insira 3 notas entre 0 e 20")
repita
escreval ("Nota 1?")
leia(nota1)
ate(nota1>=0)e (nota1<=20)
repita
escreval ("Nota 2?")
leia(nota2)
ate(nota2>=0)e (nota2<=20)
repita
escreval ("Nota 3?")
leia(nota3)
ate(nota3>=0)e (nota3<=20)
nf<-media
pro
fimalgoritmo

Anónimo disse...

algoritmo "3notas"
var nota1,nota2,nota3:inteiro
notaf: real

funcao media: real
var
med: real
inicio
med<-(nota1+nota2+nota3)/3
retorne med
escreval ("A média das notas é:",med)
fimfuncao

procedimento pro
var
inicio

se (notaf>=0) e (notaf<5)entao
escreval ("Mau")
senao
se (notaf>=5) e (notaf<10)entao
escreval ("Medíocre")
senao
se (notaf>=10) e (notaf<14)entao
escreval ("Suficiente")
senao
se (notaf>=14) e (notaf<18)entao
escreval ("Bom")
senao
escreval("Muito Bom")
fimse
fimse
fimse
fimse
fimprocedimento


inicio
escreval ("Insira 3 notas entre 0 e 20")
repita
escreval ("Nota 1?")
leia(nota1)
ate(nota1>=0)e (nota1<=20)
repita
escreval ("Nota 2?")
leia(nota2)
ate(nota2>=0)e (nota2<=20)
repita
escreval ("Nota 3?")
leia(nota3)
ate(nota3>=0)e (nota3<=20)
notaf<-media
pro
fimalgoritmo

Diogo N4