terça-feira, 18 de novembro de 2014

Módulo 3 - Exercício 2

Elabore um algoritmo em WebPortugol que leia um número inteiro entre 1 e 9 a apresenta a tabuada de multiplicação respetiva.

Por exemplo, se o programa ler o número 5, deverá escrever,

5 x 1  = 5
5 x 2  = 10
5 x 3  = 15 
5 x 4  = 20 
5 x 5  = 25
5 x 6  = 30
5 x 7  = 35
5 x 8  = 40
5 x 9  = 45
5 x 10 = 50     

A resolução é individual. Cada aluno coloca a sua resolução num comentário a este post.

28 comentários:

Ronaldo Veloso disse...
Este comentário foi removido pelo autor.
Anónimo disse...

programa tabuada
declaracoes
inteiro m, b, x
inicio
escreva ("tabuada do número: ")
leia (m)
se (m<10)entao
para b<-1 ate 10 passo 1
x<-b*m
escreva("\n",m,"x",b,"=",x)
fimpara
fimse
fim




Rui Monte nº25

Anónimo disse...

programa tabuada
declaracoes
inteiro n,t,r
inicio
escreva ("Numero para a tabuada?")
leia (n)
para t<-1 ate 9 passo 1
r<-n * t
escreva ("\n",n, " * ", t, " = ",r)
fimpara
fim


Ruben Morim nº24

Ronaldo Veloso disse...
Este comentário foi removido pelo autor.
Rui Monte disse...

programa tabuada
declaracoes
inteiro m, b, x
inicio
escreva ("tabuada do número: ")
leia (m)
se (m<10 e m>0)entao
para b<-1 ate 10 passo 1
x<-b*m
escreva("\n",m,"x",b,"=",x)
fimpara
fimse
fim

Rui Monte

Anónimo disse...

programa overpaw
declaracoes
inteiro x, y,z
inicio
escreva ("Escreva o numero?")
leia (x)
para y<-1 ate 9 passo 1
z<-x * y
fimpara
escreva ("\n",x, " x ", y, "=",z)

fim
Diogo n4

Carlos Escrivães disse...

programa tabuada
declaracoes
inteiro x, y,result
inicio
escreva ("Qual o numero?")
leia (x)
para y<-1 ate 10 passo 1
result<-x * y
escreva ("\n",x, " x ", y, "=",result)
fimpara
fim

Ronaldo Veloso disse...

programa jnln
declaracoes
inteiro num, tab,result
inicio
escreva ("Numero para calcular?")
leia (num)
se (num>0 e num<10) entao
para tab<-1 ate 10 passo 1
result<-num * tab
escreva ("\n",num, " x ", tab, "=",result)
fimpara
fimse
fim

Ricardo Lage disse...

programa dasbhfad
declaracoes
inteiro a, b,c
inicio
escreva ("insira um número: ")
leia (a)
se (a<10)entao
para b<-1 ate 10 passo 1
c<-b*a
escreva("\n",a,"x",b,"=",c)
fimpara
fimse
fim


Ricardo Lage n°21

Tiago Monteiro disse...

programa tabuada
declaracoes
inteiro n, nu ,a
inicio
escreva ("Insira um número da tabuada?")
leia (n)
se(n<10 e n>0)entao
para nu<-1 ate 9 passo 1
a<-nu*n
escreva("\n",n,"*",nu,"=",a)
fimpara
fimse
fim

Tiago Monteiro nº28

Anónimo disse...

programa tabuada
declaracoes
inteiro n,t,r
inicio
escreva ("Qual o numero?")
leia (n)
se(n<10)entao
para t<-2 ate 9 passo 2
result<-n*t
escreva ("\n",n, " x ", t, "=",r)
fimpara
fim
Pedro Carreira Nº19

Anónimo disse...

programa tab
declaracoes
inteiro n, t, r
inicio
escreva ("tabuada do número: ")
leia (n)
se (n<10 e n>0)entao
para t<-1 ate 10 passo 1
r<-n*t
escreva("\n",n,"x",t,"=",r)
fimpara
fimse
fim

Ricardo Nº22

Diogo Matos disse...

programa tabuada
declaracoes
inteiro n,t,r
inicio
escreva ("\nInsira o numero da tabuada até a do 10? ")
leia (n)
se (n>0 e n<=10) entao
para t<-1 ate 10 passo 1
r<-n * t
escreva ("\n",n, " x ", t, "=",r)
fimpara
fimse
fim

Diogo Matos Nº6

Anónimo disse...

programa tabuada
declaracoes
inteiro y
inteiro resultado
inteiro x


inicio

escreva ("Qual é o numero?")
leia (y)
para x<-1 ate 9 passo 1
resultado<-x * y
escreva ("n",y, " x ", x, "=",resultado)
fimpara
fim


Marcelo Cruz

Anónimo disse...

programa tabuada
declaracoes
inteiro l,m,n
inicio
escreva ("Escreva o numero?")
leia (l)
para m<-1 ate 9 passo 1
n<-x*y
fimpara
escreva ("\n",l,"x"m,"=",n
fimpara
fimse
fim


Luis Carreira nº13

Anónimo disse...

programa Tabuada
declaracoes
inteiro numero, tabuada,resultado
inicio
escreva ("Numero para calcular?")
leia (numero)
se (numero>0 e numero<10) entao
para tabuada<-1 ate 10 passo 1
resultado<-numero * tabuada
escreva ("\n",numero, " x ", tabuada, "=",resultado)
fimpara
fimse
fim

José Ricardo Cruz Nº11
Paulo Neves Nº 18

Anónimo disse...

programa tabuada
declaracoes
inteiro x, y,result
inicio
escreva ("Qual o numero para calcular ?")
leia (x)
para y<-1 ate 10 passo 1
result<-x * y
escreva ("\n",x, " x ", y, "=",result)
fimpara
fim




Luis Costa

Tiago Parente disse...

programa tabuada
declaracoes
inteiro n,t,r,x
inicio
escreva ("Qual o numero?")
leia (n)
se(n<10)entao
para t< -1 ate 9 passo 1
result< -n*t
escreva("n "x " t "="r)
fimpara
fim

Ricardo Lage disse...

programa dasbhfad
declaracoes
inteiro a, b,c
inicio
escreva ("insira um número: ")
leia (a)
se (a<10 e a>0)entao
para b<-1 ate 10 passo 1
c<-b*a
escreva("\n",a,"x",b,"=",c)
fimpara
fimse
fim


Ricardo Lage n°21

Sérgio Torres disse...

programa slkdhsihças
declaracoes
inteiro a, b,c
inicio
escreva ("insira um número: ")
leia (a)
se (a<10)entao
para b<-1 ate 10 passo 1
c<-b*a
escreva("\n",a,"x",b,"=",c)
fimpara
fimse
fim

Anónimo disse...


programa tabuada
declaracoes
inteiro n,t,r
inicio
escreva ("Qual o numero?")
leia (n)
se(n<10)entao
para t<-2 ate 9 passo 1
result<-n*t
escreva ("\n",n, " x ", t, "=",r)
fimpara
fim
Pedro Carreira Nº19

Fábio Gomes disse...

programa tabuada
declaracoes
inteiro u, t, x
inicio
escreva ("insira um número: ")
leia (u)
se (u<10)entao
para t<-1 ate 10 passo 1
x<-t*u
escreva("\n",u,"x",t,"=",x)
fimpara
fimse
fim


Fábio gomes nº7

Anónimo disse...

programa atabuada
declaracoes
inteiro num, n, x
inicio
escreva ("Escreve o número qe queiras ver a tabuada: ")
leia (num)
se (num<10)entao
para n<-1 ate 10 passo 1
x<-n*num
escreva("\n",num,"x",n,"=",x)
fimpara
fimse
fim

Carlos Correia nº3

Joao Sencadas disse...

programa tabuada1a9
declaracoes
inteiro mul, n, x
inicio
escreva ("insira um número de 1 a 9: ")
leia (mul)
se (mul<10)entao
para n<-1 ate 10 passo 1
x<-n*mul
escreva("\n",mul,"x",n,"=",x)
fimpara
fimse
fim


João Sencadas Nº9

Anónimo disse...

programa tabuada
declaracoes
inteiro n,t,r
inicio
escreva ("qual é o numero da tabuada?")
leia (n)
se (n<10 e n>0)entao
para t<-1 ate 10 passo 1
r<-n*t
escreva("\n",n,"x",t,"=",r)
fimpara
fimse
fim


Luis Quinta nº14

Rui Monte disse...

programa tabuada
declaracoes
inteiro m, b, x
inicio
escreva ("Insira um número entre 1 e 9: ")
leia (m)
b<-1
se (m>0 e m<10) entao
enquanto (b<=10) faca
x<-b*m
escreva("\n",m,"x",b,"=",x)
b<-b+1
fimenquanto
senao
escreva ("\nNúmero INVÁLIDO")
fimse
fim

Tiago Monteiro disse...

programa tabuada2
declaracoes
inteiro n, nu ,a
inicio
escreva("Insira um número de 1 a 9\n")
leia(n)
nu<-1
se(n>0 e n<10)entao
enquanto(nu<=10)faca
a<-nu+1
escreva("\n",n,"*",nu,"=",a)
nu<-nu+1
fimenquanto
fimse
fim

Tiago Monteiro nº28

Diogo Matos disse...

programa tabuada
declaracoes
inteiro m, b, x
inicio
escreva ("Insira um número entre 1 e 10: ")
leia (m)
b<-1
se (m>0 e m<=10) entao
repita
x<-b*m
escreva("\n",m,"x",b,"=",x)
b<-b+1
enquanto(b<=10)
fimse
fim
Diogo Matos Nº6