terça-feira, 25 de novembro de 2014

Exercício no VisuAlg

Fazer um algoritmo no VisuAlg para ler 3 notas (entre 0 e 20) de um aluno, calcular a média das 3 notas e apresentar a classificação qualitativa:

- média entre 0 e 4: Mau
- média entre 5 e 9: Medíocre
- média entre 10 e 13: Suficiente
- média entre 14 e 17: Bom
- média entre 18 e 20: Muito Bom

22 comentários:

Ricardo Lage disse...

algoritmo "semnome"
// Função :Notas
// Autor :Lage
// Data : 25/11/2014
// Seção de Declarações
var
um ,dois ,tres:inteiro
m :real

inicio
escreval (" Escreva a primeira nota :")
leia (um)
escreval (" Escreva a segunda nota :")
leia (dois)
escreval (" Escreva a terceira nota :")
leia (tres)
m<-(um+dois+tres)/3
escreval ("A média das suas notas é: " ,m)
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>=5) e (m<=9) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<=13)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<=17)
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse






fimalgoritmo


RICARDO LAGE N° 21

Carlos Escrivães disse...

algoritmo "Notas"
// Função :
// Autor :Carlos Escrivães
// Data : 25/11/2014
// Seção de Declarações
var
a,b,c: inteiro
d: real
inicio
escreval("Escreva a primeira nota")
leia(a)
escreval("Escreva a segunda nota")
leia(b)
escreval("Escreva a terceira nota")
leia(c)
d<-(a+b+c)/3
escreval("A média das notas é:",d)
se(d>=0) e (d<=4) entao
escreval(A média é má!")
senao
se(d>=5) e (d<=9) entao
escreval("A média é medíocre!")
senao
se(d>=10) e (d<=13) entao
escreval("A média é suficiente!")
senao
se(d>=14) e (d<=17) entao
escreval("A média é boa!")
senao
se(d>=18) e (d<=20) entao
escreval("A média é muito boa!")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/11/2014
// Seção de Declarações
var
nota1,nota2,nota3,media:real
inicio
escreva("Digite a primeira nota:")
leia(nota1)
escreva("Digite a segunda nota:")
leia(nota2)
escreva("Digite a terceira nota:")
leia(nota3)
media <- (nota1+nota2+nota3)/3
se (media>0)e(media<=4)entao
escreva(" A sua média é:"Má,media)
senao
se (media>4) e (media<=10) entao
escreva(" A sua média é:Medíocre",media)
senao
se (media>10) e (media<=13) entao
escreva("A sua média é:Suficiente",media)
senao (media>13) e (media<18)
escreva("A sua média é:Bom",media)
se (media>=18) e (media<=20)
escreva ("A sua média é: Muito Bom",media)
fimse
fimse
fimse
fimalgoritmo

Ricardo Nova Nº22

Diogo Matos disse...

algoritmo "e"

var
x:inteiro
y:inteiro
z:inteiro
w:real
inicio
escreval("insira a sua primeira media")
leia(x)
escreval("insira a sua segunda media")
leia(y)
escreval("insira a su terceira media")
leia(z)
w<-(x+y+z)/3
escreval ("A média das suas notas é de: " ,w)
se(w=0)e(w<=4)entao
escreval ("A média é má ")
senao
se (w>=5) e (w<=9) entao
escreval("A méda é medíocre ")
senao
se (w>=10)e(w<=13)entao
escreval ("A média é suficiente ")
senao
se (w>=14)e (w<=17)
escreval("A média é boa ")
senao
se (w>=18)e (w<=20)
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse

fimalgoritmo

Diogo Matos Nº6

Tiago Monteiro disse...

algoritmo "média"
// Função :
// Autor :
// Data : 25/11/2014
// Seção de Declarações
var
a, b, c: inteiro
d: real
inicio
escreva("Insira a sua nota:")
leia (a)
escreval("Insira outra nota:")
leia (b)
escreval("Insira outra nota:")
leia (c)
d<-(a+b+c)/3
se(d>=0) e (d<=4)entao
escreva("A sua média é mau")
senao
se(d>4) e (d<10)entao
escreva("A sua média é Medíocre")
senao
se(d>=10) e (d<=13)entao
escreva("A sua média é Sufeciente")
senao
se(d>13) e (d<18)entao
escreva("A sua média é Bom")
senao
se(d>=18) e (d<=20)entao
escreva("A sua média é Muito Bom")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Tiago Monteiro nº28

Rui Monte disse...

algoritmo "semnome"
// Função : Média das Notas
// Autor : KnifeDeath
// Data : 25/11/2014
// Seção de Declarações
var
x, y, z :inteiro
m: real
inicio
// Seção de Comandos
escreva ("Insira uma nota: ")
leia (x)
escreval("")
escreva ("Insira outra nota: ")
leia (y)
escreval("")
escreva ("Insira outra nota: ")
leia (z)
escreval("")
m<-(x+y+z)/3
escreva ("A média das notas inserida é: ")
se (m>=0) e (m<=4)entao
escreva ("Mau")
senao
se (m>4) e (m<10) entao
escreva ("Medíocre")
senao
se (m>=10) e(m<14) entao
escreva ("Suficiente")
senao
se (m>=14) e (m<=17) entao
escreva ("Bom")
senao
escreva ("Muito bom")
fimse
fimse
fimse
fimse
fimalgoritmo

Anónimo disse...

algoritmo ""
autor: Pedro Carreira nº19
var:
n1,n2,n3,m:real

inicio
escreva("digite a primeira nota:")
leia(n1)
escreva("digite a segunda nota:")
leia(n2)
escreva("digite a terceira nota:")
leia(n3)
m<-(n1+n2+n3/3)
escreval ("A média das suas notas é: " ,m)
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>=5) e (m<=9) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<=13)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<=17)
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse

Anónimo disse...

algoritmo ""
autor: Pedro Carreira nº19
var:
n1,n2,n3,m:real

inicio
escreva("digite a primeira nota:")
leia(n1)
escreva("digite a segunda nota:")
leia(n2)
escreva("digite a terceira nota:")
leia(n3)
m<-(n1+n2+n3/3)
escreval ("A média das suas notas é: " ,m)
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>=5) e (m<=9) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<=13)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<=17)
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse

Anónimo disse...

algoritmo "notamedia"
// Função :
// Autor :
// Data : 25/11/2014
// Seção de Declarações
var nt1,nt2,nt3,notafinal : real
inicio
escreval ("Insira 3 notas")
escreval ("Nota 1")
leia (nt1)
escreval ("Nota 2")
leia (nt2)
escreval ("Nota 3")
leia (nt3)
notafinal:=(nt1+nt2+nt3)/3
se (notafinal>=0) e (notafinal<=4) entao
escreval ("Mau")
senao
se (notafinal>4) e (notafinal<10) entao
escreval("Medíocre")
senao
se (notafinal>=10) e (notafinal<=13) entao
escreval ("Suficiente")
senao
se (notafinal>13) e (notafinal<18) entao
escreval ("Bom")
senao
se (notafinal>=18) e (notafinal<=20) entao
escreval("Muito Bom")
fimse
fimse
fimse
fimse
fimse

fimalgoritmo



Ruben Morim Nº24

Anónimo disse...

algoritmo "media"
// Função :Notas
// Autor :ze e paulo
// Data : 25/11/2014
// Seção de Declarações
var
um ,dois ,tres:inteiro
m :real

inicio
escreval (" Escreva a primeira nota :")
leia (um)
escreval (" Escreva a segunda nota :")
leia (dois)
escreval (" Escreva a terceira nota :")
leia (tres)
m<-(um+dois+tres)/3
escreval ("A média das suas notas é: " ,m)
se(m=0)e(m<=4)entao
escreval ("A média é má ")
senao
se (m>=5) e (m<=9) entao
escreval("A méda é medíocre ")
senao
se (m>=10)e(m<=13)entao
escreval ("A média é suficiente ")
senao
se (m>=14)e (m<=17)
escreval("A média é boa ")
senao
se (m>=18)e (m<=20)
escreval("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo


josé ricardo nº 11
paulo neves nº18

Anónimo disse...

algoritmo "Media de 3 notas de um aluno"
// Função :
// Autor :Diogo Pereira nº4
// Data : 25-11-2014
// Seção de Declarações
var
n1 , n2 , n3 , media: real

inicio
// Seção de Comandos
escreval ("Insire a 1ª nota")
leia (n1)
escreval ("Insire a 2ª nota")
leia (n2)
escreval ("Insire a 3ª nota")
leia (n3)
media <- ((n1+n2+n3)/3)
se (media >=0) e (media<=4) entao
escreval ("Sua media é" ,media, " Mau")
fimse
se (media >4) e (media <=9) entao
escreval ("Sua media é" ,media, " Mediocre")
fimse
se (media >=9) e (media <13) entao
escreval ("Sua media é" ,media, " Sufeciente")
fimse
se (media >13) e (media <18) entao
escreval ("Sua media é" ,media, " Bom")
fimse
se (media >=18) e (media <=20) entao
escreval ("Sua media é" ,media, " Muito Bom")
fimse
fimalgoritmo

Tiago Parente disse...

algoritmo avaliaçao
// Função :
// Autor :tiago parente
// Data : 25/11/2014
// Seção de Declarações
var
a,b,c:inteiro
d:real
inicio
escreval("A primeira nota")
leia(a)
escreval("A segunda nota")
leia(b)
escreval("A terceira nota")
leia(c)
d >(a+b+c)/ 3
escreval("A média das notas é:",d)
se(d > =0) e (d < =4) entao
escreval("A média é muito má!")
senao
se(d > = 5) e (d < =9) entao
escreval("A média é mediocre!")
senao
se(d > =10) e (d < =13) entao
escreval("A média é suficiente!")
senao
se(d > =14) e (d < =17) entao
escreval("A média é Boa!")
senao
se(d > =18) e (d < =20) entao
escreval("A média é MUITO BOA!")
fimalgoritmo

Ronaldo Veloso disse...

algoritmo "Notas"
// Função : Faz senefrei
// Autor : Ronaldo
// Data : 25/11/2014
// Seção de Declarações
var nota1,nota2,nota3,nf : real


inicio

escreval ("Insira 3 notas entre 0 e 20")
repita
escreval ("Nota 1?")
leia(nota1)
ate(nota1>=0)e (nota1<=20)
repita
escreval ("Nota 2?")
leia(nota2)
ate(nota2>=0)e (nota2<=20)
repita
escreval ("Nota 3?")
leia(nota3)
ate(nota3>=0)e (nota3<=20)
nf:=(nota1+nota2+nota3) / 3
se (nf>=0) e (nf<=4)entao
escreval ("Mau")
senao
se (nf>=5) e (nf<=9)entao
escreval ("Medíocre")
senao
se (nf>=10) e (nf<=13)entao
escreval ("Suficiente")
senao
se (nf>=14) e (nf<=17)entao
escreval ("Bom")
senao
escreval("Muito Bom")
fimse
fimse
fimse
fimse
fimalgoritmo


RONALDO VELOSO Nº23

Carlos Lopes disse...

algoritmo "notas"
// Função :Ler as notas
// Autor :Carlos Lopes
// Data : 25/11/2014
// Seção de Declarações
var
n1, n2, n3, media :real
inicio
// Seção de Comandos
escreval ("Insira a primeira nota?")
leia(n1)
escreval ("Insira a segunda nota?")
leia(n2)
escreval ("Insira a terceira nota?")
leia(n3)
media<-(n1+n2+n3/3)
escreva ("A media é:",media)
se (media >=0) e (media<=4) entao
escreval (media,"=","MAU")
fimse
se (media>4) e (media<10) entao
escreval (medias,"=","Medíocre")
fimse
se (media>=10) e (media<=13) entao
escreval (media, "=","Suficiente")
fimse
se (media>13) e (media<18) entao
escreval (media, "=","Bom")
fimse
se (media >=18) e (media<=20) entao
escreval (media, "=","Muito Bom")
fimse
fimalgoritmo

Anónimo disse...

algoritmo "notas"
// Função :notas
// Autor :Marcelo Cruz
// Data : 25/11/2014
// Seção de Declarações
var
n1,n2,n3:inteiro
media: real
inicio
// Seção de Comandos
escreva("Insira primeira nota(0 a 20)")
leia(n1)
escreva("Insira segunda nota(0 a 20)")
leia(n2)
escreva("Insira terceira nota(0 a 20)")
leia(n3)

media<-(n1+n2+n3)/3

se (media>=0) e (media<=4) entao
escreva("A sua media e Mau")
senao
se (media>=4) e (media<=9) entao
escreva("A sua media e Mediocre")
senao
se (media>=10) e (media<=13) entao
escreva(" A sua media e Sufeciente")
senao
se (media>=14) e (media<=17) entao
escreva("A sua media e Bom")
senao
se (media>=18) e (media<=20)entao
escreva("A sua media e Muito Bom")
fimse
fimse
fimse
fimse
fimse

fimalgoritmo

joao sencadas disse...

algoritmo "Notas"
// Função :Notas
// Autor :João Sencadas
// Data : 25/11/2014
// Seção de Declarações
var
t1,t2,t3,media: real
inicio
escreva ("Insira sua primeira nota:")
leia(t1)
escreva ("Insira sua segunda nota:")
leia(t2)
escreva ("Insira sua terceira nota:")
leia(t3)
media<-(t1+t2+t3)/3
se(media>=0)e(media<=4) entao
escreval("Teve de media:",media," MAU")
fimse
se(media>4)e(media<=9) entao
escreval("Teve de media:",media," Medíocre")
fimse
se(media>9)e(media<=13) entao
escreval("Teve de media:",media," Suficiente")
fimse
se(media>13)e(media<=17) entao
escreval("Teve de media:",media," Bom")
fimse
se(media>17)e(media<=20) entao
escreval("Teve de media:",media," Muito BOM")
fimse
fimalgoritmo

João Sencadas nº9

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :Luis
// Data : 25/11/2014
// Seção de Declarações
var
n1,n2,n3,m:real
inicio
escreva("Digite a primeira nota:")
leia(n1)
escreva("Digite a segunda nota:")
leia(n2)
escreva("Digite a terceira nota:")
leia(n3)
m <- (n1+n2+n3)/3
se (m>0)e(m<=4)entao
escreva(" A sua média é:"Má,media)
senao
se (m>4) e (m<=10) entao
escreva(" A sua média é:Medíocre",media)
senao
se (m>10) e (m<=13) entao
escreva("A sua média é:Suficiente",media)
senao (m>13) e (m<18)
escreva("A sua média é:Bom",media)
se (m>=18) e (m<=20)
escreva ("A sua média é: Muito Bom",media)
fimse
fimse
fimse
fimalgoritmo
Luis Carlos N 12

Sérgio Torres disse...

algoritmo "Notas"
// Função :
// Autor :Sérgio Torres
// Data : 25/11/2014
// Seção de Declarações
var
a,b,c: inteiro
d: real
inicio
escreval("Escreva a primeira nota")
leia(a)
escreval("Escreva a segunda nota")
leia(b)
escreval("Escreva a terceira nota")
leia(c)
d<-(a+b+c)/3
escreval("A média das notas é:",d)
se(d>=0) e (d<=4) entao
escreval(A média é má!")
senao
se(d>=5) e (d<=9) entao
escreval("A média é medíocre!")
senao
se(d>=10) e (d<=13) entao
escreval("A média é suficiente!")
senao
se(d>=14) e (d<=17) entao
escreval("A média é boa!")
senao
se(d>=18) e (d<=20) entao
escreval("A média é muito boa!")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Anónimo disse...

algoritmo "notas"
// Função : notas
// Autor : João Pedro
// Data : 25/11/2014
// Seção de Declarações
var
um,dois,tres:inteiro
media:real
inicio
escreval (" Escreva a primeira media :")
leia (um)
escreval (" Escreva a segunda media:")
leia (dois)
escreval (" Escreva a terceira media :")
leia (tres)
media<-(um+dois+tres)/3
se(media>=0) e (media<=6)entao
escreva("A média não é boa ")
senao
se (media>=5) e (media<=9) entao
escreval("A média é um pouco melhor ")
senao
se (media>=11)e(media<=13)entao
escreval ("A média é suficiente ")
senao
se (media>=15)e (media<=17)
escreval("A média é muito boa ")
senao
se (media>=16)e (media<=20)
escreval("A média é boa ")
fimse
fimse
fimse
fimse
fimse

Anónimo disse...


algoritmo "semnome"
// Função :Notas
// Autor :Luís Carreira"Notas"
// Data : 25/11/2014
// Seção de Declarações
var:
d,e,f,g:inteiro

inicio
escreval("Escreva a primeira nota")
leia(d)
escreval("Escreva a segunda nota")
leia(e)
escreval("Escreva a terceira nota")
leia(f)
g<-(d+e+f)/3
escreval("A média das notas é:",g)
se(g>=0) e (g<=4) entao
escreval(A média é má!")
senao
se(g>=5) e (g<=9) entao
escreval("A média é medíocre!")
senao
se(g>=10) e (g<=13) entao
escreval("A média é suficiente!")
senao
se(g>=14) e (g<=17) entao
escreval("A média é boa!")
senao
se(g>=18) e (g<=20) entao
escreval("A média é muito boa!")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Anónimo disse...

algoritmo "exercicio"
// Função :Notas
// Autor :Luis Quinta
// Data : 25/11/2014
// Seção de Declarações
var
m1,m2,m3:inteiro
m:real
inicio
//Seção de comandos
escreva(" Escreva a primeira nota :")
leia(m1)
escreva(" Escreva a segunda nota :")
leia(m2)
escreva(" Escreva a terceira nota :")
leia(m3)

m<-(m1+m2+m3)/3
se(m=0)e(m<=4)entao
escreva("A média é má ")
senao
se (m>=5) e (m<=9) entao
escreva("A méda é medíocre ")
senao
se (m>=10)e(m<=13)entao
escreva("A média é suficiente ")
senao
se (m>=14)e (m<=17)
escreva("A média é boa ")
senao
se (m>=18)e (m<=20)
escreva("A média é muito boa ")
fimse
fimse
fimse
fimse
fimse
fimalgoritmo



Luis Quinta nº14

Alex Trifyutsyanu disse...

algoritmo "semnome"
// Função :
// Autor : Alex
// Data : 25/11/2014
// Seção de Declarações
var
nota1,nota2,nota3 , media :real
inicio
escreva ( "Qaul a 1º nota?")
leia (nota1)
escreva ("Qual a 2º nota?")
leia (nota2)
escreva ("Qual a 3º nota?")
leia (nota3)
media <- (nota1+nota2+nota3)/3)
se (media >=0) e (media<=4)entao
escreva ( media ,"=" , "Mau" )
fimse
se (media>4) e (media<10) entao
escreva (media, "=", "Mediocre")
fimse
se (media>=10) e (media<=13) entao
escreva (media, "=", "Suficiente")
fimse
se (media>13) e (media<18) entao
escreva (media,"=", "Bom")
fimse
se (media>=18) e (media<=20) entao
escreva (media,"=", "Muito Bom")
fimse
fimalgoritmo