terça-feira, 4 de novembro de 2014

Continuação Exercício Módulo 2 - Instruções Cíclicas (3)

Alterar o exercício do post anterior de forma a que no início do programa seja pedido o número de valores inteiros que serão lidos. Ou seja, em vez de serem 20 valores inteiros, é o utilizador que indica quantos valores devem ser lidos.


21 comentários:

Anónimo disse...

programa trab4
declaracoes
inteiro x
inteiro Maior
inteiro Menor
inteiro Total
real Media
inteiro v
inteiro v2
inicio
escreva ("O número de valores inteiros que serão lidos: ")
leia (v2)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<-1
se (v2>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<v2)
fimse
se (v=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nA soma de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (Media)

fim

Rui Monte nº25

Ronaldo Veloso disse...

programa numeros
declaracoes
real med
inteiro num, max, min, cont, lidos, pedido
inicio
escreva ("Quantos numeros quer usar?\n")
leia (pedido)
escreva ("\nPode começar a inserir os numeros!\n")
leia (num)
escreva ("\n")
max <- num
min <- num
cont <- 1
lidos <- num
enquanto (cont < pedido) faca
leia (num)
escreva ("\n")
lidos <- (lidos + num)
cont <- (cont + 1)
se (num>max) entao
max <- num
fimse
se (num<min) entao
min <- num
fimse
fimenquanto
med <- lidos / pedido
escreva ("\n------RESULTADOS------")
escreva ("\nNumero maximo lido: ")
escreva (max)
escreva ("\nNumero minimo lido: ")
escreva (min)
escreva ("\nSoma de todos lidos: ")
escreva (lidos)
escreva ("\nMedia: ")
escreva (med)
escreva ("\n--------------------------------")
fim



Ronaldo nº23

Ricardo Lage disse...

programa sequencia
declaracoes
inteiro x
real media
inteiro v
inteiro a
inteiro Maior
inteiro Menor
inteiro Total
inicio
escreva ("Quantos numeros inteiros serão lidos:")
leia (a)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<- 1
se (a>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<a)
fimse
se (v<20) entao
media <- Total / a
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nO total de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (media)
fim

Anónimo disse...

programa numeros
declaracoes
real med
inteiro num, max, min, cont, lidos, pedido
inicio
escreva ("Quantos numeros queres usar?\n")
leia (pedido)
escreva ("\nEscreve os numeros\n")
leia (num)
escreva ("\n")
min <- num
max <- num
lidos <- num
cont <- 1
enquanto (cont < pedido) faca
leia (num)
escreva ("\n")
lidos <- (lidos + num)
cont <- (cont + 1)
se (nummax) entao
max <- num
fimse
fimenquanto
med <- lidos / pedido
escreva ("\nMedia: ")
escreva (med)
escreva ("\nMaximo: ")
escreva (max)
escreva ("\nMinimo: ")
escreva (min)
escreva ("\nSoma: ")
escreva (lidos)
fim


Ruben Morim nº24

Joao Sencadas disse...

programa numeros
declaracoes
inteiro numero, soma, maior, menor, contador, numeros
real media

inicio
escreva ("Quantos numeros deseja inserire?")
leia (numeros)
contador <- 0
soma <- 0
escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- 1

soma <- numero
maior <- numero
menor <- numero

enquanto ( contador < numeros ) faca

escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- contador + 1

soma <- soma + numero

se ( numero > maior ) entao
maior <- numero
senao
se ( numero < menor ) entao
menor <- numero
fimse
fimse
fimenquanto
media <- soma / numeros

escreva( "\nMaior numero lido: ", maior )
escreva( "\nMenor numero lido: ", menor )
escreva( "\nSoma dos números lidos : ", soma )
escreva( "\nMédia dos números lidos: ", media )
fim

João Sencadas Nº9

Diogo Matos disse...

programa numeros
declaracoes
inteiro numero, soma, maior, menor, contador, numeros
real media

inicio
escreva ("Quantos numeros quer inserir?")
leia (numeros)
contador <- 0
soma <- 0
escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- 1

soma <- numero
maior <- numero
menor <- numero

enquanto ( contador < numeros ) faca

escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- contador + 1

soma <- soma + numero

se ( numero > maior ) entao
maior <- numero
senao
se ( numero < menor ) entao
menor <- numero
fimse
fimse
fimenquanto
media <- soma / numeros

escreva( "\nMaior numero lido: ", maior )
escreva( "\nMenor numero lido: ", menor )
escreva( "\nSoma dos números lidos : ", soma )
escreva( "\nMédia dos números lidos: ", media )
fim
Diogo Matos Nº6

Anónimo disse...

programa triward
declaracoes
inteiro numero, soma, maior, menor, contador,z
real media

inicio
escreva ("Quantos numeros deseja inserir?")
leia (z)
contador <- 0
soma <- 0
escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- 1

soma <- numero
maior <- numero
menor <- numero

enquanto ( contador < z ) faca

escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- contador + 1

soma <- soma + numero

se ( numero > maior ) entao
maior <- numero
senao
se ( numero < menor ) entao
menor <- numero
fimse
fimse
fimenquanto
media <- soma / z

escreva( "\nMaior numero lido: ", maior )
escreva( "\nMenor numero lido: ", menor )
escreva( "\nSoma dos números lidos : ", soma )
escreva( "\nMédia dos números lidos: ", media )
fim

Diogo Nº 4

Carlos Lopes disse...
Este comentário foi removido pelo autor.
Anónimo disse...

programa Identifi
declaracoes
inteiro x
inteiro Maior
inteiro Menor
inteiro Total
real Media
inteiro v1
inteiro v2
inicio
escreva ("\nO número de valores inteiros que serão lidos: \n")
leia (v2)
escreva ("\nInsira um número inteiro:\n")
leia (x)
Maior <- x
Menor <- x
Total <- x
v1<-1
se (v2>1) entao
repita
v1<-v1+1
escreva ("\nInsira um número inteiro:\n ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v1<v2)
fimse
se (v1=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é\n ")
escreva (Maior)
escreva ("\nO número menor é\n ")
escreva (Menor)
escreva ("\nA soma de todos os números é\n ")
escreva (Total)
escreva ("\nA média é \n")
escreva (Media)
fim
Ricardo Nova nº22

Sérgio Torres Nº26 disse...

programa sequencia
declaracoes
inteiro x
real media
inteiro v
inteiro a
inteiro Maior
inteiro Menor
inteiro Total
inicio
escreva ("Quantos numeros inteiros serão lidos:")
leia (a)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<- 1
se (a>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<a)
fimse
se (v<20) entao
media <- Total / a
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nO total de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (media)
fim

Carlos Escrivães disse...

programa sequencia
declaracoes
inteiro x
real media
inteiro Maior
inteiro Menor
inteiro Total
inteiro v
inteiro y

inicio
escreva ("Quantos numeros inteiros serão lidos:")
leia (y)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<- 1
se (y>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<y)
fimse
se (v<20) entao
media <- Total / y
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nO total de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (media)
fim

Carlos Lopes disse...

programa exercício
declaracoes
inteiro x
inteiro Maior
inteiro Menor
inteiro Total
real Media
inteiro v
inteiro v2
inicio
escreva ("O número de valores inteiros que serão lidos: ")
leia (v2)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<-1
se (v2>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<v2)
fimse
se (v=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nA soma de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (Media)

fim
Carlos Lopes

Anónimo disse...

programa Identifi
declaracoes
inteiro x
inteiro Maior
inteiro Menor
inteiro Total
real Media
inteiro v1
inteiro v2
inicio
escreva ("\nO número de valores inteiros que serão lidos: \n")
leia (v2)
escreva ("\nInsira um número inteiro:\n")
leia (x)
Maior <- x
Menor <- x
Total <- x
v1<-1
se (v2>1) entao
repita
v1<-v1+1
escreva ("\nInsira um número inteiro:\n ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v1<v2)
fimse
se (v1=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é\n ")
escreva (Maior)
escreva ("\nO número menor é\n ")
escreva (Menor)
escreva ("\nA soma de todos os números é\n ")
escreva (Total)
escreva ("\nA média é \n")
escreva (Media)
fim

José Ricardo Nº11
Paulo Neves Nº18

Anónimo disse...

programa sequencia2
declaracoes
inteiro a
inteiro Maior
inteiro Menor
inteiro T
real Media
inteiro b
inteiro c
inicio
escreva ("O número de valores inteiro que serão lidos:")
leia (c)
escreva ("\nInsira um número inteiro:")
leia (a)
Maior <-a
Menor <-a
T<-a
b<-1
se (c>1) entao
repita
b<-b+1
escreva ("\nInsira um número inteiro:")
leia (a)
se (Maiora) entao
Menor <-a
fimse
T <- T + a
enquanto (b<c)
fimse
se (b=c) entao
Media <- T / c
fimse
escreva("\nO número maior é ")
escreva(Maior)
escreva("\nO número menor é ")
escreva(Menor)
escreva("\nA média é ")
escreva(media)
escreva("\nO Total é ")
escreva(T)
fim

Tiago Monteiro nº28

Capitao Tig disse...

programa numero
declaracoes
inteiro y
inteiro maior
inteiro menor
inteiro total
real media
inteiro v
inteiro v2
inicio
escreva (O número de valores inteiros que serão lidos:)
leia (v2)
escreva (Insira um número inteiro:)
leia (y)
maior <- y
menor <- y
total <- y
v<-1
se (v2>1) entao
repetir
v<-v+1
escreva (Insira um número inteiro:)
leia (y)
se (maior y) entao
Menor - y
fimse
Total - total + y
enquanto (v<v2)
fimse
se (v=v2) entao
media - total / v2
escreva (O numero maior é)
escreva (maior)
escreva (O numero menor é)
escreva (menor)
escreva (A soma de todos os números é)
escreva (total)
escreva (A média é)
escreva (media)

fim

Anónimo disse...

programa numeros
declaracoes
inteiro x,maior,menor,total,v,v2
real Media
inicio
escreva ("O número de valores inteiros que serão lidos: ")
leia (v2)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<-1
se (v2>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<v2)
fimse
se (v=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nA soma de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (Media)

fim

Pedro Carreira nº19

Anónimo disse...

programa numeros
declaracoes
real med
inteiro pedido, lidos, min, num, max,cont
inicio
escreva ("Quantos numeros queres usar?\n")
leia (pedido)
escreva ("\nEscreve os numeros\n")
leia (num)
escreva ("\n")
min <- num
max <- num
lidos <- num
cont <- 1
enquanto (cont < pedido) faca
leia (num)
escreva ("\n")
lidos <- (lidos + num)
cont <- (cont + 1)
se (nummax) entao
max <- num
fimse
fimenquanto
med <- lidos / pedido
escreva ("\nMedia: ")
escreva (med)
escreva ("\nMaximo: ")
escreva (max)
escreva ("\nMinimo: ")
escreva (min)
escreva ("\nSoma: ")
escreva (lidos)
fim

carlos correia

Anónimo disse...

programa numeros
declaracoes
inteiro numero, soma, maior, menor, contador, numeros,
real media

inicio
escreva ("Quantos numeros quer inserir?")
leia (numeros)
contador <- 0
soma <- 0
escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- 1

soma <- numero
maior <- numero
menor <- numero

enquanto ( contador < numeros ) faca

escreva( "\nInsira um número inteiro: " )
leia( numero )
contador <- contador + 1

soma <- soma + numero

se ( numero > maior ) entao
maior <- numero
senao
se ( numero < menor ) entao
menor <- numero
fimse
fimse
fimenquanto
media <- soma / numeros

escreva( "\nMaior numero lido: ", maior )
escreva( "\nMenor numero lido: ", menor )
escreva( "\nSoma dos números lidos : ", soma )
escreva( "\nMédia dos números lidos: ", media )
fim

Alex Trifyutsyanu disse...

programa vinte
declaracoes
inteiro num, max, min, cont, lidos, pedido
real med
inicio
escreva ("Quantos numeros?\n")
leia (pedido)
escreva ("\nInsira os numeros!\n")
leia (num)
escreva ("\n")
max <- num
min <- num
cont <- 1
lidos <- num
enquanto (cont < pedido) faca
leia (num)
escreva ("\n")
lidos <- (lidos + num)
cont <- (cont + 1)
se (num>max) entao
max <- num
fimse
se (num<min) entao
min <- num
fimse
fimenquanto
med <- lidos / pedido
escreva ("\n:RESULTADO:")
escreva ("\nNumero maximo lido- ")
escreva (max)
escreva ("\nNumero minimo lido- ")
escreva (min)
escreva ("\nSoma de todos lidos-")
escreva (lidos)
escreva ("\nMedia: ")
escreva (med)
fim

Alex tgp2

Marcelo Cruz disse...

programa numeros
declaracoes
real media
inteiro contador, lidos, pedido, numero, maximo, minimo

inicio

escreva ("Quantos numeros vai usar?\n")

leia(pedido)

escreva("\nPode começar a introduzir os numeros!\n")

leia(numero)

escreva ("\n")
minimo <- numero
maximo <- numero
contador <- 1
lidos <- numero

enquanto (contador < pedido) faca

leia (numero)

escreva ("\n")
lidos <- (lidos + numero)
contador<- (contador + 1)
se (numero>maximo) entao
maximo <- numero
fimse
se (numero<minimo) entao
minimo <- numero
fimse

fimenquanto
media <- lidos / pedido
escreva ("\nResultados")

escreva ("\nNumero minimo lido:")

escreva (minimo)

escreva ("\nNumero maximo lido:")

escreva (maximo)

escreva ("\nMedia:")


escreva (media)

escreva ("\nSoma de todos lidos:")

escreva (lidos)



fim

Marcelo Cruz

Anónimo disse...

programa numeros
declaracoes
inteiro x
inteiro Maior
inteiro Menor
inteiro Total
real Media
inteiro v
inteiro v2
inicio
escreva ("O número de valores inteiros que serão lidos: ")
leia (v2)
escreva ("\nInsira um número inteiro: ")
leia (x)
Maior <- x
Menor <- x
Total <- x
v<-1
se (v2>1) entao
repita
v<-v+1
escreva ("\nInsira um número inteiro: ")
leia (x)
se (Maiorx) entao
Menor <- x
fimse
Total <- Total + x
enquanto (v<v2)
fimse
se (v=v2) entao
Media <- Total / v2
fimse
escreva ("\nO número maior é ")
escreva (Maior)
escreva ("\nO número menor é ")
escreva (Menor)
escreva ("\nA soma de todos os números é ")
escreva (Total)
escreva ("\nA média é ")
escreva (Media)

fim
Luis Carlos nº12