terça-feira, 2 de dezembro de 2014

Exercício com Subprogramas - Tabuada

Fazer no VisuAlg o exercício da tabuada que foi apresentado neste post.

O programa deve agora no programa principal ler o número (entre 1 e 10) e depois chamar um procedimento, passando o número lido como parâmetro, que escreve a tabuada desse número. O programa principal deve validar se o número lido está dentro do intervalo pretendido. Em caso contrário, apresenta uma mensagem de erro.

Responder com um comentário a este post.

11 comentários:

Rui Monte disse...

algoritmo "semnome"
var
x,t:inteiro

procedimento Tabuada (y,t:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
t<-y*n
escreval (y,"*",n,"=",t)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (x)
escolha x
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(x,t)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Ricardo Lage disse...

algoritmo "semnome"
var
a,b:inteiro

procedimento Tabuada (a,b:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
b<-a*n
escreval (a,"*",n,"=",b)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (a)
escolha a
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(a,b)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Carlos Escrivães disse...

algoritmo "tabuada"
var
a,b:inteiro

procedimento Tabuada (y,b:inteiro)
var
c:inteiro
inicio
para c<-1 ate 10 passo 1 faca
b<-y*c
escreval (y,"*",c,"=",b)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (a)
escolha a
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(a,b)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Tiago Monteiro disse...

algoritmo "tabuada"
var
n1,n2:inteiro

procedimento Tabuada (n1,n2:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
n2<-n1*n
escreval (n1,"*",n,"=",n2)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (n1)
escolha n1
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(n1,n2)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Anónimo disse...

algoritmo "tabuada"
var:
x, n, p:inteiro
procedimento tabuada(x,n,p:inteiro)
fimprocedimento
inicio
para n<-1 ate 10 passo 1 faca
t<-y*n
escreval (y,"*",n,"=",t)
fimpara

inicio

escreva("Insira um número (entre 1 e 10): ")
leia (x)
escolha x
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(x,t)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Pedro Carreira nº19

Anónimo disse...

algoritmo "semnome"
var
x,t:inteiro

procedimento Tabuada (i,t:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
t<-i*n
escreval (i,"*",n,"=",t)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (x)
escolha x
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(x,t)
outrocaso
Escreval("número desconhecido")
fimescolha

fimalgoritmo

Luis Quinta nº14

Anónimo disse...

algoritmo "tabuada"
var
n1,n2:inteiro

procedimento Tabuada (n1,n2:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
n2<-n1*n
escreval (n1,"*",n,"=",n2)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (n1)
escolha n1
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(n1,n2)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Ruben Morim nº24

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor :Marcelo Cruz
// Data : 02/12/2014
// Seção de Declarações
var
var
x,tabuada:inteiro

procedimento Tabuada (y,tabuada:inteiro)
var
numero:inteiro
inicio
para n<-1 ate 10 passo 1 faca
tabuada<-y*numero
escreval (y,"*",numero,"=",tabuada)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (x)
escolha x
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(x,tabuada)
outrocaso
Escreval("número não reconhecido")
fimescolha

fimalgoritmo

Diogo Matos disse...

algoritmo "tab"
var
X:inteiro
n:inteiro
p:inteiro
tab:inteiro
procedimento tabuada(t:inteiro)
inicio
se (x >= 1) e (x <= 10) entao
para n<-1 ate 10 passo 1 faca
p<-x*n
escreval( "", x, " x ", n, " = ", p )
fimpara
senao
escreval( "\nNúmero inválido." )
fimse
fimprocedimento
inicio
escreval("Insira o número (entre 1 e 10):")
leia( x )
para n<-1 ate 10 passo 1 faca
p<-x*n
escreval( "", x, " x ", n, " = ", p )
fimpara
fimalgoritmo
diogo matos

Alex Trifyutsyanu disse...

algoritmo "semnome"
var
a,b:inteiro

procedimento tabuada (a,b:inteiro)
var
n:inteiro
inicio
para n<-1 ate 10 passo 1 faca
b<-a*n
escreval (a,"*",n,"=",b)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10): ")
leia (a)
escolha a
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(a,b)
outrocaso
Escreval("número inválido")
fimescolha

fimalgoritmo

Anónimo disse...

algoritmo "semnome"
// Função :
// Autor : João Pedro
// Data : 02/12/2014
// Seção de Declarações
var
n:inteiro

inicio
// Seção de Comandos
para n-1 ate 10 passo 1 faca
t<-y n
escreval (y,n,t)
fimpara
fimprocedimento
inicio
escreva("Insira um número (entre 1 e 10)")
leia 6
escolha ("Insira uma letra")
leia x
caso 1,2,3,4,5,6,7,8,9,10
Tabuada(x,t)
outrocaso
Escreval("Número inválido")
fimescolha

fimalgoritmo
fimalgoritmo